[Jibri] Recording on a custom port with the stable version of Jitsi-meet

Hello! I successfully implemented a reverse proxy service, Squid, for recording sessions using Jibri on the Jitsi-meet server configured with a custom port. The Squid listens to access from Jibri on port 443 and transfers the packets to Jitsi-meet listening on the custom port 8443, as shown in the figure below. We need not configure to transfer web socket data since the Squid doesn’t distinguish web sockets from other HTTPS connections. The configuration file of the Squid is as follows;

https_port 443 accel no-vhost defaultsite=www.mysite.com tls-cert=fullchain.pem tls-key=privkey.pem

acl mysites dst 127.0.0.1 port 8443 url_regex www.mysite.com
http_access allow mysites
cache_peer www.mysite.com parent 8443 0 no-query originserver ssl no-digest no-netdb-exchange name=proxy_SSL
cache_peer_access proxy_SSL allow mysites
cache_peer_access proxy_SSL deny !mysites

forwarded_for off

Secondary, I added two lines to the Nginx configuration file for Jitsi, /etc/nginx/sites-available/www.mysite.com.conf, to avoid error 400, “The plain HTTP request was sent to HTTPS port” on the Nginx as follows.

server {
listen 8443 ssl;
listen [::]:8443 ssl;
server_name www.mysite.com;
ssl on; # <— added
error_page 497 https://$host:8443$request_uri; # <— added

I believe that the method is the easiest and minimum load for servers to record sessions on the stable version of Jitsi-meet with a custom port.

Best regards,
Yoichi Mizomata
Web portal: BEYOND THE NET: TOOLS

1 Like

Hello! Damencho. Thank you for your quick reply.

I confirmed that Jibri recording with the custom port, 8443, is certainly enabled after adding ‘only’ the line below to the XMPP environment configuration:

base-url = “https://www.mysite.com:8443

I had thought that the four files must be merged and compiled from the source code in the pull request “Adding XMPP Port option to config file,” #398. Thank you again.

Best regards,
Yoichi Mizomata
Web portal: BEYOND THE NET: TOOLS

I didn’t understand what issue you are trying to solve. The static contents are already cached by browser and the big traffic comes from the audio/video packets which are transfered over UDP/10000. The HTTPS traffic seems negligible.

I had wanted to record sessions of Jitsi-meet using Jibri on a custom port. I successfully implemented the reverse proxy to connect to Jitsi-meet from Jibri. However, I found only one thing for the customizing: giving the string to the variable, base-url, in the XMPP environment configuration from the above Damencho’s reply. So, I removed the reverse proxy service.

Please read from the thread for more details. “Jitsi Recording is not working on custom port”.