Jibri recording not working, still not working


#1

After correcting a typing error in the recorder passwords on both machines there still is no success with recording. I am unable to find the reason for misfunction!

This log entry seems relevant in Jicofo log:
Jicofo 2019-02-01 19:07:35.375 SCHWERWIEGEND: [40] org.jitsi.jicofo.recording.jibri.JibriSession.log() Unable to find an available Jibri, can’t start

It seems to correlate with the entry in the Jibri log:
2019-02-01 19:05:35.652 SCHWERWIEGEND: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘88.117.245.227:5222’ failed because: /88.117.245.227 exception: java.net.ConnectException: Verbindungsaufbau abgelehnt (Connection refused)

However, each machine can ping the other one in due time, find the ping stats amended in the log files.
jicofo.log (27.5 KB)
jicofoERROR_WARNING.log (5.7 KB)
JVB.log (53.1 KB)
JVBErrorWarning.log (1.0 KB)
jibri.log (2.9 KB)


#2

The connection exception is almost certainly your issue (or, at least, the first one to solve) however we can’t very easily debug your network. You say that, from the jibri machine, you can ping 88.117.245.227? Have you tried telnetting from Jibri to 88.117.245.227:5222 and see if that manages to at least ‘connect’?


#3

Hi @toni,

As @bbaldino correctly pointed, this must be some issue with the connections. Try telnet or if you have used a hosting service like AWS please check the security rules.

Abhijit


#4

Thank you for your hint! After opening port 5222 on main machine connection was established. But:

<?xml version='1.0'?></stream:error></stream:stream>

Verbindung zu Host verloren.
PS C:\Users\tk_6>

Recording still impossible…

What can I do?


#5

Where do you see this error? Plus can you please translate

Abhijit