Jibri recording : How to hide "Fellow Jitster" user when recording is ON

Hello the community,

All is in the title :slight_smile: I successfully install Jibri on my Jitsi self hosting server, recording works properly, But I would like to hide the user “Fellow Jitster” that appear when recording is in progress…
I was already be able to change its name but I would like to completly hide this “user” on the screen when recording is started…

Is it possible and if yes how can I configure this topic ?

Thanks by advance,

Vincent

By following the docs jibri uses recorder.domain.com virtual host to connect. Add that host as hiddenDomain in config.js.

Hello damencho,

I added into the file /etc/jitsi/meet/mydomain.com-config.js : hiddenDomain: ‘recorder.mydomain.com’,
(the same indiated in jibri.conf: domain = "recorder.mydomain.com

But it’s seems that not working, I always have the user Fellow Jitster when recording…
Maybe I do anything wrong ?

Vincent

Do you see the setting if you go on https://yourdomain.com/config.js ?

Then maybe jibri is not using the credentials and the domain to join.

Yes I can see all the setting I did by browsing to this URL

Check again the jibri config and the jibri logs … Check whether the user jibri is configured to use is created, check files in var lib prosody

I checked but I don’t understand what could be wrong…

The
hiddenDomain: ‘recorder.mydomain.com’,
in the config file is on the “center” of the file (not on the hosts {} part) … Could it be the problem ?

Attached the jibri log.0.txt file when I do a recording, I didn’t notice anything related to the user come into the room for recording…
log.0.txt (9.7 KB)

Share your config.js and your jibri.conf.

Hello Freddie,

Here the config.js and the jibri.conf

I change my domain name by “mydomain.com” to “hide” real one :wink:

config.js : Mar 18 4:27 PM - Codeshare
jibri.js : Mar 18 4:26 PM - Codeshare

Vincent

Sorry the “upload” function failed when I wanted to share this files…

Why did you add it in the ‘hosts’ block in your config.js?
Move it down to, for instance, line #262, right after // liveStreamingEnabled: false,

It was a “test” that doesn’t works… Yes I can remove it.

I leave the line hiddenDomain: ‘recorder.mydomain.com’, on line #1090
Is it important to put it on line #262 after “liveStreamingEnabled: false,” ?
Do I need to remove it on line #1090 .

I will try and let you know

Thanks Freddie

I try to put this line on #262 after liveStreamingEnabled: false, and remove from line #1090 but it doesn’t works.
When I start recording I already have the User that appears (I named it “Utilisateur”)

I restart jitsi and jibri services before trying…

Did you remove it from the hosts section? You can’t have it set twice.

That name must be registered as “recorder” and the user added to recorder.mydomain.com.

Yes

Hum Ok I think I understand : I will try and let you know.

Thanks

When I followed tuto I did a think like this :
prosodyctl register jibri auth.meet.myfirewall.org JibrisPass
prosodyctl register recorder recorder.meet.myfirewall.org RecordersPass

Do I need to add “Utilisateur” with this method ?

How can I list users already registered for the recording part ?

I don’t think I really understand. Where you’re setting this user “Utilisateur”? The recorder user is specified in jibri.conf and added to recorder.mydomain.com.

grep password /var/lib/prosody/recorder*/accounts/recorder.dat
sed -n ‘/call.login/, /}/p’ /etc/jitsi/jibri/jibri.conf | grep password

Both should match.

In the /usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME: ‘Utilisateur’,

Ok it just give me the password in the recorder.dat

Oh, sorry - I read that as you wanting to confirm the password.
To list all users, run the following:

sudo ls -l /var/lib/ *prosody* /*/accounts/*