Jibri recording failed , Current service had an error Error: QuitUnexpectedly SESSION plug:bsnoop: Input/output error

This log entry lead me to try to disable snd-aloop module as its not required now, and suddenly i have audio in my recorded videos :slight_smile:
Don’t ask me why it works
Might help someone.

as I test jibri in a container, I have no snd-aloop module either so it’s not strictly necessary.

FTR when using pulseaudio, it’s possible to enable debug by adding something like

extra-arguments=–log-target=newfile:/home/jibri/pulselog --log-level=debug

to /home/jibri/.config/pulseaudio/client.conf.

Is there a way to turn on logging for alsa device as well ?
I would like to check the issue we have had with plug:bsnoop ?

Enabling ffmpeg log-level to “trace” doesn’t give me any insights, probably because it issue happens before ffmpeg process any frame.

no idea about tracing with alsa, alas. I’m more excited about pipewire actually :slight_smile: