[Jibri] Recording Button Does not Appear


#1

Hi,

I have built jitsi-meet from source as instructed in https://github.com/jitsi/jitsi-meet . Also installed jibri from the youtube video guide.

The problem is, live streaming is working (which means jibri installation is working fine). However, I cannot manage to get the Recording button. Here is what I have done in the config.js file:

fileRecordingsEnabled: true,

// Enable the dropbox integration.
dropbox: {
    appKey: 'xxxxxxxxxxxx' // Specify your app key here.
},

// Whether to enable live streaming or not.
liveStreamingEnabled: true,

hiddenDomain: 'recorder.example.com',

Rebuilt the app, but still not working. Any idea anyone? :slight_smile: Thanks


#2

Have you checked, jibri and jicofo logs. Is jibri able to connect, does jicofo sees jibri instance?


#3

Looks like the requirements for showing the button include

  • being a moderator
  • fileRecordingsEnabled set to true in config
  • enableFeaturesBasedOnToken at least set to false (can be set to true but other work is involved I think)
  • interfaceConfig TOOLBAR_BUTTONS including recording