Jibri recording but no audio and video

Heya, I’ve been trying to setup jitsi stack with jibri as well for both using docker-compose and my own kubernetes manifest. So the setup I was done is jitsi + jibri using docker-compose, and sometimes I turn off the jibri docker-compose and deploy jibri on top of kubernetes.

When I try to record using jibri on kubernetes, it records just fine. However when I played back the recording result turns out that jibri does not record anything, just showing grey page (no sound and no audio recorded).

I checked the logs on jibri for both docker-compose and kubernetes are the same. But when I check the jvb logs for both cases (jibri docker-compose vs jibri kubernetes), I realize that seems like the jvb does not recognize the jibri IP, hence maybe the only participant in that conference is only the user itself.

Here I attach the jvb logs for both cases
jvblogs.compose.txt (21.0 KB) jvblogs.k8s.txt (15.2 KB)

Any ideas how to solve this? or maybe anybody can tell me which is the cause of the problem?
Many thanks in advance

I had a similar issue earlier, turned out my java version was wrong. It needs JDK-8

Check if you have installed java 8 jdk. java -version

Show us the jibri log.

@Nirav_Shah I use docker image with tag below


and if I exec into the container and run java -version then I get:

openjdk version “1.8.0_252”
OpenJDK Runtime Environment (build 1.8.0_252-8u252-b09-1~deb9u1-b09)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

@Kali here I attach the jibri logs jibrilogs.k8s.txt (18.2 KB)
I replaced my jitsi domain to my.domain, and eventually update the /etc/hosts file so that when I access meet.my.domain it will resolve to the VM that holds the jitsi stack private IP address

If the recording starts both as a core and as a ram, you’re fine.
Is Jibri a separate server from jitsi?
I had your problem because i had java 11.
Does Jibri solve jitsi’s fqdn?
From the log i see an IP 10.x.y.z. Why?

@fatahnuram there’s an open issue with adoptjdk - Debian 10 Buster: javax.net.ssl.SSLHandshakeException: PKIX path building failed in jicofo.log and jvb.log · Issue #8243 · jitsi/jitsi-meet · GitHub

What do you get when you run update-alternatives --config java?

@Kali yes jibri been setup on the different server from other jitsi components, and they can talk using private IP (hence you see 10.xx.xx.xx there). I actually add to jibri container’s /etc/hosts file, so when I run nslookup meet.my.domain it will resolve to the jitsi public IP but when I run ping meet.my.domain it will ping to the jitsi’s private IP address. But if I try to resolve other subdomains from *.meet.my.domain it doesn’t resolve anything. I think jibri and jitsi will resolve it internally?

@Freddie I run the command on all containers (jibri on k8s, jibri on docker-compose, and jvb on docker-compose) and all of them giving me the same response:

There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java
Nothing to configure.

But … If you create a pinpoint in your internal DNS server that points to the private IP of your jitsi. In my setup so i did.

If you run nslookup or host xyz.yourdomain.xyz it always solves it but with the private IP.

Any host making calls in the internal network, MPLS, SD-Wan, vpn. Traffic is internal. My jitsi is under nat (dmz). I don’t know your… But if you tell me about IP 10.x.y.z i think it’s under nat.

I also have jibri separated by jitsi

I connected to the jibri server and i started a recording… But in the logs i didn’t see IP but FQDN.

@Kali can you record and produce audio and video? I’m still getting blank page for recording result though. Or maybe you have any tips about how to debug this? Thank you

i can play the videos without any problems. And recordings work like live streaming works.

The problem you have, i had it when i installed java 11 by mistake.

I have removed java, jibri. Then i installed java 8 as the first package then everything else.

I had a few minor file permissions issues but they can be fixed in seconds.

When you run this command sudo apt-get install default-jre-headless ffmpeg curl alsa-utils icewm xdotool xserver-xorg-input-void xserver-xorg-video-dummy don’t install Java because it updates Java from 8 to 11.

So you just run sudo apt-get install ffmpeg curl alsa-utils icewm xdotool xserver-xorg-input-void xserver-xorg-video-dummy

My jibri is not in dmz but it is in lan. The video files is immediately available for my colleagues. The videos are not stored inside the jibri server but in a storage with read-only permissions.

I don’t use docker…

@Kali okay I understand the situation you’re in, but unfortunately I use docker here, but thanks for sharing your experience

It is a pleasure to share…

You try to install jibri by following this guide. GitHub - jitsi/jibri: Jitsi BRoadcasting Infrastructure

It’s a quick guide.

If you search the forum there are 2 posts created by @Freddie both for installation and for problems and traboshuting. They are very recent posts…

I’m always available to help…

Did you manage with bad recording on jibri docker container? I`ve encountered with same problem.

What damencho proposes in this post fixed the audio video bug for me:

Hi all,

any one fixed the no audio and video in jibri recording files,
it jitsi meet latest version only getting issue, old jitsi meet working fine same jibri.
I have changed trusted-domains = [ "recorder to recording still same issue.

Have you tried without jibri, does 3 way call works?

normal calls working fine. I dont thing jvb issue.

I have upgraded jibri, now all are normal and working. thanks to all