Jibri problem

Now I think there is a small progress the error message is not displayed directly, it can that I must wait a few seconds after its launching so that it can give the error message (recording is stopped), should I add the resources at the level of the RAM?

Get This first :
image

and after 10 seconde i get this and it’s stopped automatically :

image

In the directory i found this : when the record is on :
image

And after the record is stopped by himself after maybe 5 seconde :
image

The record is deleted !!!

Jibri creates a temporary directory to put the recorded file but since it cannot get any media for a while, it stops and deletes the directory.

Looks like Chrome cannot join the meeting or crashes while trying.

You may check chromedriver log which is in /tmp/

1 Like

As requested , find above the chrome.log

jicofo.txt (59.1 KB)

:frowning:

Thanks you very much Mr.Emrah

I repeat all installation and it didn’t work again

I don’t know what’s the problem ; i did everything in the good way without error and i increase the ressource !!!

image

The recording starts after a few seconds it stops and I receive an error message, I have never experienced this in older versions of jitsi, please is there anyone for help

For the installation I installed the installation following this repository :

Please help !!!

You may try jitsi-jibri-installer if your distro is in the supported distribution list

or the following one for cluster setup

1 Like

Do you have token authentication?

1 Like

Yes i want to use JWT for authentification that why i uses Switnet repository ; but now i will go with your suggested repository ; should i crash the instance ? and i should have two subdomains ?

1 - meet.myplatforms.com and turn.myplatforms.com because in the first one i use just meet.my platforms.com ?

Did you add the recorder account into admins list in prosody config?

admins = { "focus@auth.jitsi.yourdomain.com", "recorder@recorder.jitsi.yourdomain.com" }
1 Like

I ran your script; I think it deleted my old installation (switnet-ltd); now I get an error

I will add these two sub-domains to (myplatforms.com) and continue

I don’t know if it would cause a problem if I continued the installation on the same server without creating a new instance and start a fresh installation

I think the missing part in your old setup is the admins list. recorder should be in the list when token authentication is enabled.

The message about turn means that you do not have DNS A record for turn domain.

You mean here in /etc/prosody/prosody.cfg.lua ?

i should add :

`admins = { "focus@auth.meet.myplatforms.com", "recorder@recorder.meet.myplatforms.com" }`

Nope.

/etc/prosody/conf.d/your-domain.cfg.lua

in Component "conference.jitsi.yourdomain.com"

1 Like

Here is my file :
meet-myplatforms.txt (6.7 KB)

Thanks you very much Emrah for your support !!

line 89

1 Like

I changed the line as requested !

and now I get a direct error message without even waiting : :pensive:

image

Did you restart all services?

Yes ofc i reboot the instance

So, there should be something else too. Did you check Jibri logs again? Is there a new error message?

I get this from Jicofo

Can you check the jibri service?

systemctl status jibri