Jibri not working

I
Sorry my English
I had Install jitsi meet conference and now I have to jibri record but not working also after more attempts.

Here is the error:
/var/log/jitsi/jibri/log.0.txt
Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 27: No configuration setting found for key ‘signing-key-path’

Can you help me please?

Thanks

Attach all Jibri logs please.

Hi
I’m sorry but when upload file logs the website shows an error “Sorry, new users can not upload attachments”.
Below I have copied and pasted the “log0.txt” /var/log/jitsi/jibri/.
Let me know if you need all the logs. Although I don’t know how to share all the files. Thanks

<?xml version="1.0" encoding="UTF-8" standalone="no"?> 2021-03-23T10:47:02 1616496422771 0 org.jitsi.jibri.webhooks.v1.JwtInfo INFO org.jitsi.utils.logging2.LoggerImpl log 1 got jwtConfig: {} 2021-03-23T10:47:02 1616496422799 1 org.jitsi.jibri.webhooks.v1.JwtInfo INFO org.jitsi.utils.logging2.LoggerImpl log 1 Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 27: No configuration setting found for key 'signing-key-path' 2021-03-23T10:47:03 1616496423407 2 org.jitsi.jibri.Main INFO org.jitsi.utils.logging2.LoggerImpl log 1 Using port 8001 for internal HTTP API 2021-03-23T10:47:03 1616496423429 3 org.jitsi.jibri.webhooks.v1.WebhookClient FINE org.jitsi.utils.logging2.LoggerImpl log 15 Updating 0 subscribers of status 2021-03-23T10:47:04 1616496424280 4 org.jitsi.jibri.api.xmpp.XmppApi INFO org.jitsi.utils.logging2.LoggerImpl log 15 Saw Jibri's state change to Idle 2021-03-23T10:47:04 1616496424282 5 org.jitsi.jibri.api.xmpp.XmppApi INFO org.jitsi.utils.logging2.LoggerImpl log 1 Connecting to xmpp environment on test.prova.it with config XmppEnvironment(name=prod environment, xmppServerHosts=[test.prova.it], xmppDomain=test.prova.it, controlLogin=XmppCredentials(domain=auth.test.prova.it, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.meet.test.prova.it, roomName=JibriBrewery, nickname=jibri), sipControlMuc=XmppMuc(domain=internal.auth.test.prova.it, roomName=JibriBrewery, nickname=jibri), callLogin=XmppCredentials(domain=record.test.prova.it, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=, usageTimeoutMins=60, trustAllXmppCerts=true) 2021-03-23T10:47:04 1616496424284 6 org.jitsi.jibri.api.xmpp.XmppApi INFO org.jitsi.utils.logging2.LoggerImpl log 15 Jibri reports its status is now Idle, publishing presence to connections 2021-03-23T10:47:04 1616496424296 7 org.jitsi.jibri.api.xmpp.XmppApi INFO org.jitsi.utils.logging2.LoggerImpl log 1 The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted 2021-03-23T10:47:04 1616496424358 8 org.jitsi.jibri.Main INFO org.jitsi.utils.logging2.LoggerImpl log 1 Using port 8000 for HTTP API 2021-03-23T10:47:04 1616496424411 9 org.jitsi.xmpp.mucclient.MucClient WARNING org.jitsi.utils.logging2.LoggerImpl log 25 Disabling certificate verification! 2021-03-23T10:47:05 1616496425075 10 org.jitsi.xmpp.mucclient.MucClient INFO org.jitsi.utils.logging2.LoggerImpl log 25 Connected. 2021-03-23T10:47:05 1616496425075 11 org.jitsi.xmpp.mucclient.MucClient INFO org.jitsi.utils.logging2.LoggerImpl log 25 Logging in. 2021-03-23T10:47:05 1616496425458 12 org.jivesoftware.smack.AbstractXMPPConnection SEVERE org.jivesoftware.smack.AbstractXMPPConnection callConnectionAuthenticatedListener 25 Exception in authenticated listener java.lang.RuntimeException: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.auth.meet.test.prova.it: XMPPError: remote-server-not-found - cancel. Generated by auth.test.prova.it org.jitsi.xmpp.mucclient.MucClient$1 authenticated 287 org.jivesoftware.smack.AbstractXMPPConnection callConnectionAuthenticatedListener 1297 org.jivesoftware.smack.AbstractXMPPConnection afterSuccessfulLogin 572 org.jivesoftware.smack.tcp.XMPPTCPConnection afterSuccessfulLogin 379 org.jivesoftware.smack.tcp.XMPPTCPConnection loginInternal 444 org.jivesoftware.smack.AbstractXMPPConnection login 491 org.jivesoftware.smack.AbstractXMPPConnection login 448 org.jitsi.xmpp.mucclient.MucClient lambda$getConnectAndLoginCallable$7 681 org.jitsi.retry.RetryStrategy$TaskRunner run 193 java.util.concurrent.Executors$RunnableAdapter call 511 java.util.concurrent.FutureTask run 266 java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask access$201 180 java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask run 293 java.util.concurrent.ThreadPoolExecutor runWorker 1149 java.util.concurrent.ThreadPoolExecutor$Worker run 624 java.lang.Thread run 748

@damencho any ideas? weird that it seems to be complaining about remote-server-not-found, but it initially connected ok?

jitsi working and all right.
jibri.conf
jibri {
id = “”
single-use-mode = false
recording {
recordings-directory = “/srv/recordings/”
finalize-script = “/usr/local/bin/finalize_recording.sh”
}

chrome {
    flags = [
        "--use-fake-ui-for-media-stream",
        "--start-maximized",
        "--kiosk",
        "--enabled",
        "--disable-infobars",
        "--autoplay-policy=no-user-gesture-required",
       #"--ignore-certificate-errors"
]
}

api {
http {
external-api-port = 5222
internal-api-port = 8001
}
xmpp {
// See example_xmpp_envs.conf for an example of what is expected here
environments = [
{
name = “prod environment”
xmpp-server-hosts = [“test.prova.it”]
xmpp-domain = “test.prova.it”

                control-muc {
                    domain = "internal.auth.test.prova.it"
                    room-name = "JibriBrewery"
                    nickname = "jibri"
                }

                control-login {
                    domain = "auth.test.prova.it"
                    username = "jibri"
                    password = "jibriauthpass"
                }

                sip-control-muc {
                    domain = "internal.auth.test.prova.it"
                    room-name = "JibriBrewery"
                    nickname = "jibri"
                }

                call-login {
                    domain = "record.test.prova.it"
                    username = "recorder"
                    password = "jibrirecorderpass"
                }

                strip-from-room-domain = "conference."
                usage-timeout = 0

                trust-all-xmpp-certs = true
      }
  ]
}

}
stats {
enable-stats-d = true
}

call-status-checks {
    no-media-timeout = 30 seconds
    all-muted-timeout = 10 minutes
    default-call-empty-timeout = 30 seconds
}
jwt-info {
	// The path to a .pem file which will be used to sign JWT tokens used in webhook
	// requests.  If not set, no JWT will be added to webhook requests.
 	signing-key-path = "/"

	// The kid to use as part of the JWT
	# kid = "key-id"

	// The issuer of the JWT
	# issuer = "issuer"

	// The audience of the JWT
	# audience = "audience"

 // The TTL of each generated JWT.  Can't be less than 10 minutes.
 # ttl = 1 hour
 }

}

This error is normally when you send a message addressed to a jid which is not lolcal to the xmpp server.

Hi
I remove jitsi and jibri and reinstall and I found that in the old configuration I did not install snd-aloop because apt install linux-generic is wrong to Ubuntu 20 from AWS server but it worked " linux-modules-extra-gcp ".
Thank you all for your interest for my problem.
How close the question?