Jibri not working in private ip

Hello everyone
I installed using docker-jitsi-meet-stable-7287 on cloud provider.
Test by opening all port on firewall.

#This Solution > Recording can work perfectly.
VM1 (docker web_1/prosody_1/jicofo_1/jvb_1) on mydomain.com EIP (Public IP)
VM2 (docker jibri_1) on EIP (Public IP)

Next Step > Is it possible that only jibri use private ip?

Ex

VM1 (docker web_1/prosody_1/jicofo_1/jvb_1) on mydomain.com EIP (Public IP)
VM2 (docker jibri_1) on (Private IP 192.168.0.22)

I have tested VM2 using private IP.

#Solution 1 (unsuccessful)
VM2 (docker jibri_1)
jibri.conf
xmpp-server-hosts = [“192.168.0.22”]
xmpp-domain = “mydomain.com

#Solution 2 (unsuccessful)
VM2 (docker jibri_1)

  • update /etc/hosts

192.168.0.22 mydomain.com
192.168.0.22 xmpp.mydomain.com

jibri.conf
xmpp-server-hosts = [“xmpp.mydomain.com”]
xmpp-domain = “mydomain.com

Where did I miss it?

Does JVB publish its local IP as an ICE candidate?

I haven’t done it yet.
Where do I need to add?

This is my jvb.conf

videobridge {
    ice {
        udp {
            port = 10000
        }
    }
    apis {
        xmpp-client {
            configs {

                shard0 {
                    HOSTNAME = "xmpp.mydomain.com"
                    PORT = "5222"
                    DOMAIN = "auth.mydomain.com"
                    USERNAME = "jvb"
                    PASSWORD = "8b03454d7be902bb588e572c4a034658"
                    MUC_JIDS = "jvbbrewery@internal-muc.mydomain.com"
                    MUC_NICKNAME = "12c01f072904"
                    DISABLE_CERTIFICATE_VERIFICATION = true
                }

            }
        }
        rest {
            enabled = false
        }
    }
    rest {
        shutdown {
            enabled = false
        }
    }
    stats {
        enabled = true
    }
    websockets {
        enabled = true
        domain = "mydomain.com"
        tls = true
        server-id = "172.18.0.4"
    }
    http-servers {
        private { 
          host = 0.0.0.0
        }
        public {
            host = 0.0.0.0
            port = 9090
        }
    }

    }

ice4j {
    harvest {
        mapping {
            stun {
addresses = [ "meet-jit-si-turnrelay.jitsi.net:443" ]
}
            static-mappings = [
{
                    local-address = "172.18.0.4"
                    public-address = "43.xxx.xxx.xxx"
                }
]
        }
    }
}

I’m not familiar with Docker setup. Probably JVB publishes only its Internet IP and the container’s internal IP and therefore Jibri cannot access JVB using its host IP address.