Jibri Nextcloud setting

I have a jitsi server running locally. Everything is working correctly. Sometimes we want to record instant meetings. I have a second nextcloud server running locally. How can I transfer recordings to nextcloud server? Could you Please help me.

My Server Info;
jitsi-meet 2.0.7439-1 all WebRTC JavaScript video conferences
jitsi-meet-prosody 1.0.6260-1 all Prosody configuration for Jitsi Meet
jitsi-meet-turnserver 1.0.6260-1 all Configures coturn to be used with Jitsi Meet
jitsi-meet-web 1.0.6260-1 all WebRTC JavaScript video conferences
jitsi-meet-web-config 1.0.6260-1 all Configuration for web serving of Jitsi Meet
jitsi-videobridge2 2.2-9-g8cded16e-1 all WebRTC compatible Selective Forwarding Unit (SFU)

Welcome to the forum.

If you’re using the new local recording feature (and it sounds like you are), your file is saved on your machine. You would need to upload the recording to Nextcloud manually (or if Nextcloud provides a desktop app that syncs folders with their cloud storage, you can sync the folder for ‘automatic’ upload).

If you use Jibri (server-side recording), you can write a finalize script that’ll upload to a cloud service.

I couldn’t do anything with Jibri. I couldn’t find any documentation about Jibri. Can you help me

First of all, thank you very much. I did everything for the procedure. But I see this error while recording.

Record Error ;
resim

When I check, I see that the jibri service is not running. Is there an error in this file? Do you think this file configuration is correct?

/opt/jitsi/jibri/launch.sh ;

#!/bin/bash

exec /usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -Dconfig.file=“/etc/jitsi/jibri/jibri.conf” -jar /opt/jitsi/jibri/jibri.jar --config “/etc/jitsi/jibri/config.json”

Jibri Service Status;
root@meting:~# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2022-10-13 11:55:40 UTC; 880ms ago
Process: 7462 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
Main PID: 7462 (code=exited, status=1/FAILURE)

Oct 13 11:55:40 meting.xxx.com.tr systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Oct 13 11:55:40 meting.xxx.com.tr systemd[1]: Stopped Jibri Process.
Oct 13 11:55:40 meting.xxx.com.tr systemd[1]: jibri.service: Start request repeated too quickly.
Oct 13 11:55:40 meting.xxx.com.tr systemd[1]: jibri.service: Failed with result ‘exit-code’.
Oct 13 11:55:40 meting.xxx.com.tr systemd[1]: Failed to start Jibri Process.

Where did you install Jibri? Do you have a desktop environment on the server?

Just create a static user/password account on your netxloud (declare a device account in settings->security) like this
image
Then in your /etc/jitsi/jibri/config.json look similar to this (choose your own paths and file names):
// Where recording files should be temporarily stored
“recording_directory”:“/home/jibri/recordings”,
// The path to the script which will be run on completed recordings
“finalize_recording_script_path”: “/home/jibri/rclone.nextcloudsncft.upload.sh”,

make your finalize_recording_script similar to this one:

#!/bin/bash

RECORDINGS_DIR=$1

VIDEO_FILE_PATH=$(find $RECORDINGS_DIR -name .mp4)
VIDEO_FILE_NAME=${VIDEO_FILE_PATH:36}
UPLOAD_DIR_NAME=${VIDEO_FILE_NAME/%_
/}
METADATA_FILE_PATH=$(find $RECORDINGS_DIR -name *.json)

/usr/bin/rclone move $METADATA_FILE_PATH NAME_REFERRING_TO_YOUR_NEXTCLOUD_INSTANCE:YOUR_CHOSEN_DIRECTORY_ON_YOUR_NEXTCLOUD_INSTANCE_HERE/$UPLOAD_DIR_NAME -v --log-file=/var/log/jitsi/jibri/NAME_REFERRING_TO_YOUR_NEXTCLOUD_INSTANCE_upload.log
/usr/bin/rclone move $VIDEO_FILE_PATH NAME_REFERRING_TO_YOUR_NEXTCLOUD_INSTANCE:YOUR_CHOSEN_DIRECTORY_ON_YOUR_NEXTCLOUD_INSTANCE_HERE/$UPLOAD_DIR_NAME -v --log-file=/var/log/jitsi/jibri/NAME_REFERRING_TO_YOUR_NEXTCLOUD_INSTANCE_upload.log

Then create a file: .config/rclone/rclone.conf starting from your home directory with content similar to this:

[NAME_REFERRING_TO_YOUR_NEXTCLOUD_INSTANCE]
type = webdav
url = https://your.nextcloud.fqdn/remote.php/dav/files/your_nextcloud_user/
vendor = nextcloud
user = your_nextcloud_user
pass = your_static_device_nextcloud_password_created_earlier

Caveat: Whoever is recording the jitsi meet session, recording will be sent to YOUR_CHOSEN_DIRECTORY_ON_YOUR_NEXTCLOUD_INSTANCE_HERE directory belonging to your_nextcloud_user

If you have a better way to do, please share with the rest of us.