Jibri new installation

After jibri installation because of failure after upgrade the config.json file was missing, the jibri.conf only contains “jibri { }”
After adding the former config.json jibri runs but recording does not start.
Message: All recorders are currently busy…
No errors in jibri log.0.txt
No errors in jitsi log.0.txt
Jitsi jicofo.log:
Jicofo 2020-08-31 10:31:10.268 SCHWERWIEGEND: [93] org.jitsi.jicofo.recording.jibri.JibriSession.log() Unable to find an available Jibri, can’t start
Jicofo 2020-08-31 10:31:10.270 INFORMATION: [93] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Failed to start a Jibri session, all Jibris were busy
Jitsi server: Ubuntu 18.04
Jibri server: Ubuntu 20.04
Need help please! Thank you!

i configured mine using this documentation https://docs.easyjitsi.com/docs/confignewjibri

After playing around for some more hours and using the link recommended: https://docs.easyjitsi.com/docs/confignewjibri/
I filled in the jibri.conf appropriately- without success (recordings not available). Reading the lean recommendations related to jibri.conf I understand that jibri.conf replaces config.json. Obviously I misunderstood. Providing both, config.json AND jibri.conf recording worked. Strange…

config.json is still read from (and prioritized) but should be considered deprecated. jibri.conf is the new version. You should be able to provide all config in jibri.conf and have things work. There’s a config migration guide here. (Note: this morning I was made aware of a couple typos there, I will try and fix them soon).

It’s worth noting that if (like us) you are building a customised jibri and replacing existing from an old install, there is a new option in the launch script to pull in the new config file.

[ resources/debian-package ] /opt/jitsi/jibri/launch.sh

change
exec java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.jar --config “/etc/jitsi/jibri/config.json”

to
exec java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -Dconfig.file="/etc/jitsi/jibri/jibri.conf" -jar /opt/jitsi/jibri/jibri.jar --config “/etc/jitsi/jibri/config.json”

1 Like