Jibri - metadata.json with empty participants

I’ve installed Jibri on the same server as the Jitsi Meet instance and got it working (although it’s using way more memory than I had anticipated, but that’s not the issue). I’ve followed this guide: TUTORIAL - How to Install the NEW JIBRI
I’m using the Jitsi Meet/Jibri set along with Rocket Chat and wanted to make the recording available for the meeting owner using a custom method. All I need is the user name.
Rocket Chat users authenticate with LDAP and they all can start video calls with Jitsi. When starting a call from Rocket, the ‘displayName’ from LDAP is passed to Jitsi and the user is correctly shown with their full name (LDAP is set up just for Rocket, Jitsi uses JWT token from Rocket).

So while testing Jibri’s behavior in our environment, I could see that the meeting was recorded successfully along with the ‘metadata.json’. The problem is that the ‘participants’ list is always empty in that file.
Is there some additional configuration to enable saving the names of the participants?
My ‘jibri.conf’ is identical to the one in the mentioned tutorial (except the domains/Prosody users of course).

These are the contents of the ‘metadata.json’:



Make sure you enable jitsi-meet/mod_presence_identity.lua at master · jitsi/jitsi-meet · GitHub as a global module in prosody.

That was it! Thanks again Damian!

Now if you allow me change the topic a bit, but still related to Jibri behavior:
I’d like to keep the option ‘startAudioOnly’ in ‘mydomain-config.js’ to true (for privacy purposes). The problem here is that apparently setting it to true also forces the meeting to be on “Best performance” mode for all users. Maybe it’s intended to work like that, but those who turn on the video afterwards aren’t seen by other people, including the Jibri recording, unless they manually raise the setting on the top slider. So Jibri only records the audio and a full black screen.
I haven’t found any other option to keep all meetings in the “Best quality” mode while starting them with audio only.

Any clue regarding this problem?
Sorry to bother you again. Thanks!

Not a problem. This is how it is intended to work. When you set startAudioOnly everyone start in audio only mode and do not receive video till they turn it off.
You can set startAudioMuted and startVideoMuted to 0 so everyone will start muted an when they unmute the rest will see them.

Ok, I got confused with the option name ‘startVideoMuted’ (I though the video started on with the audio off), but I see the meeting forces the camera to off while keeping the quality to max. Jibri then recorded both audio and video as expected.
Thanks again!