Jibri Issues Recording (After enabling SecureDomain)

Docker Jitsi Meet, enabled Secure Domain and reloaded everything… now getting Session ID is null. Suspect it’s related to the Secure Domain but Jibri does have a prosody user

2020-06-07 08:35:36.347 FINE: [3977] org.jitsi.xmpp.mucclient.MucClientManager.log() Replacing presence extension: org.jitsi.xmpp.extensions.jibri.JibriStatusPacketExt@23f34b47
2020-06-07 08:35:36.349 FINE: [43] org.jitsi.xmpp.extensions.DefaultPacketExtensionProvider.parse() Could not add a provider for element busy-status from namespace http://jitsi.org/protocol/jibri
2020-06-07 08:35:36.349 FINE: [43] org.jitsi.xmpp.extensions.DefaultPacketExtensionProvider.parse() Could not add a provider for element health-status from namespace http://jitsi.org/protocol/health
2020-06-07 08:35:36.585 SEVERE: [3988] org.jitsi.jibri.selenium.JibriSelenium.run() An error occurred while joining the call: org.openqa.selenium.NoSuchSessionException: Session ID is null. Using WebDriver after calling quit()?
Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘a7f68fb8a24b’, ip: ‘192.168.160.7’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘4.15.0-101-generic’, java.version: ‘1.8.0_252’
Driver info: driver.version: RemoteWebDriver with stack:
org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:125)
org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:543)
org.openqa.selenium.remote.RemoteWebDriver.executeScript(RemoteWebDriver.java:480)
org.jitsi.jibri.selenium.pageobjects.CallPage$visit$1.apply(CallPage.kt:48)
org.jitsi.jibri.selenium.pageobjects.CallPage$visit$1.apply(CallPage.kt:33)
org.openqa.selenium.support.ui.FluentWait.until(FluentWait.java:248)
org.jitsi.jibri.selenium.pageobjects.CallPage.visit(CallPage.kt:47)
org.jitsi.jibri.selenium.JibriSelenium$joinCall$1.run(JibriSelenium.kt:256)
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
java.util.concurrent.FutureTask.run(FutureTask.java:266)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

2020-06-07 08:35:36.587 INFO: [3988] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2020-06-07 08:35:36.587 INFO: [3988] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call
2020-06-07 08:35:36.588 INFO: [3988] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Current service had an error, sending error iq
2020-06-07 08:35:36.588 INFO: [3988] org.jitsi.jibri.JibriManager.stopService() No service active, ignoring stop

Removed the config, redeployed the whole stack with Docker, put the important stuff back and it worked! Will keep an eye on it…