Jibri is not starting

I have followed this tutorial to setup Jibri on my server.

The configurations of my server are :
Dual core Intel(R) Xeon(R) CPU E5-2676 v3 @ 2.40GHz
and 4GB Ram

Both Jitsi and Jibri are hosted on the above server

Here’s the error that i am getting

Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-03-26 16:22:35 UTC; 18min ago
Process: 4564 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
Main PID: 4564 (code=exited, status=1/FAILURE)

Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Service hold-off time over, scheduling
restart.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Scheduled restart job, restart counter is at
5.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: Stopped Jibri Process.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Start request repeated too quickly.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Failed with result ‘exit-code’.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: Failed to start Jibri Process.

We have already gone through these issues and are unable to get jibri up and running

  • help-with-jibri-error-failed-to-start-jibri-process/84464/14
  • failed-to-start-jibri-process/20995
  • please-help-install-jibri-always-failed/72150/15 (pasting the issues name and number since it didn’t allow more than two links for a new user.)

@emrah

This is low. You need at least 8 GB for the default installation.

The unofficial jitsi-jibri-installer may be helpful

@emrah we are running servers with 4GB Ram without any issues(on AWS).

The resource issue should be when recording is started, no? The service should start at least…seems some issue with the config, may be…

Include the jibri logs

This page is no longer accessible…Use the official jibri page…

Thanks for sharing this repo will try to reinstall using it.

Here’s my config file… Please let me know if there are any issues in it.

jibri {
id = “”
single-use-mode = false
recording {
recordings-directory = “/srv/recordings”
}
streaming {
// A list of regex patterns for allowed RTMP URLs. The RTMP URL used
// When starting a stream must match at least one of the patterns in
// this list.
rtmp-allow-list = [
// By default, all services are allowed
“.*”
]
}

stats {
enable-stats-d = true
}
api{
xmpp {
environments = [
{
name = “prod environment”
xmpp-server-hosts = [“our_custom_url”]
xmpp-domain = “our_custom_url”

control-muc {
domain = “internal.auth.our_custom_url”
room-name = “JibriBrewery”
nickname = “jibri”
}

control-login {
domain = “auth.our_custom_url”
username = “jibri”
password = “Jibr1P@ssw0rd”
}

call-login {
domain = “recorder.our_custom_url”
username = “recorder”
password = “Rec0rderP@ssw0rd”
}

strip-from-room-domain = “conference.”
trust-all-xmpp-certs = true
},

]
}
}
}

Here are my jibri logs

jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-03-26 16:22:35 UTC; 2h 21min ago
Process: 4564 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
Main PID: 4564 (code=exited, status=1/FAILURE)

Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: Stopped Jibri Process.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Start request repeated too quickly.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: jibri.service: Failed with result ‘exit-code’.
Mar 26 16:22:35 ip-172-31-3-78 systemd[1]: Failed to start Jibri Process.

Thanks for the reply.

That’s the service log, can you include the jibri logs? they are /var/log/jitsi/jibri/log.#.txt

There is only one line in my logs from log.1.txt -

2021-03-26 16:22:34.561 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args

I was curious why this comma when other code blocks don’t?

Probably has nothing to do with the issue, though…

Does there need to be a space here ? “api{” as in “api {”

And there are no other files with any other content, in that directory?

there are but each one of the has the same log just the timestamp is different

Thanks for pointing out will remove it and try.

Yes there are spaces in between i guess they didn’t get reflected when i copy pasted the file.

I removed and reinstalled jibri with this config but now recording button itself is not appearing on the screen.

I have done the necessary changes in prosody and jicofo as well as added ‘recording’ in interface_config.js
and enabled fileRecordings in my domin.config file

I use the same file and it works. Verify install once again Refer GitHub - jitsi/jibri: Jitsi BRoadcasting Infrastructure

If all is good, restart all services and check.

Btw ‘start recording’ should be visible even if the conf file is empty.

okay
I think i messed up somewhere while redoing jibri…
However every file looks good to me…
Do you think problem could be in prosody or any other such package?

Do you have something in logs now?

Check few common jibri issues at Jibri not working - #11 by Prashanth