Jibri fails immediately starting live stream

Hi all.
I know this is a very common issue on the forum but I have followed all the debugging instruction in @Freddie 's tutorial along with multiple fixes from different websites but still not able to find the issue.

As soon as I start streaming I get:

grep password /var/lib/prosody/auth*/accounts/jibri.dat

The above command does not show me any password. I reran the command to register the jibri user still its not adding a password field to the above file.

Commands used to register used:

prosodyctl register jibri auth.jitsi.example.com jibriauthpass prosodyctl register recorder recorder.jitsi.example.com jibrirecorderpass

grep password /var/lib/prosody/recorder*/accounts/recorder.dat gives the correct password for recorder

My Jibri.conf:

// New XMPP environment config.
jibri {
  id = ""
  single-use-mode = false
    chrome {
        // The flags which will be passed to chromium when launching
        flags = [
          "--use-fake-ui-for-media-stream",
          "--start-maximized",
          "--kiosk",
          "--enabled",
          "--disable-infobars",
          "--autoplay-policy=no-user-gesture-required",
          "--ignore-certificate-errors",
          "--disable-dev-shm-usage"
        ]
    }
    recording {
         recordings-directory = /var/jbrecord
         finalize-script = /home/jibri/finalize_recording.sh
    }
    api {
        http {
                external-api-port = 2222
                internal-api-port = 3333
        }
        xmpp {
            environments = [
                {
                name = "Jibri Sessions"

                xmpp-server-hosts = [ "jitsi.example.com" ]
                
                xmpp-domain = "jitsi.example.com"
                control-muc {
                    domain = "internal.auth.jitsi.example.com"
                    room-name = "JibriBrewery"
                    nickname = "Live"
                }
                control-login {
                    domain = "auth.jitsi.example.com"
                    username = "jibri"
                    password = "jibriauthpass"
                }

                call-login {
                    domain = "recorder.jitsi.example.com"
                    username = "recorder"
                    password = "jibrirecorderpass"
                }

                strip-from-room-domain = "conference."

                usage-timeout = 0 hour
                trust-all-xmpp-certs = true
                }
            ]
        }
    }
    streaming {
    	rtmp-allow-list = [
      	".*"
    	]
    }
    stats {
    	enable-stats-d = true
    }
    webhook {
    	subscribers = []
    }
    call-status-checks {
    	no-media-timeout = 30 seconds

    	all-muted-timeout = 10 minutes

    	default-call-empty-timeout = 30 seconds
    }
}

Jicofo sip-communicator.properties

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.jitsi.example.com
org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=RegionBasedBridgeSelectionStrategy
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.jitsi.example.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

At the end of prosody config I have added:

Component "internal.auth.jitsi.example.com" "muc"
modules_enabled = {
"ping";
}
-- storage should be "none" for prosody 0.10 and "memory" for prosody 0.11
storage = "memory"
muc_room_cache_size = 1000
VirtualHost "recorder.jitsi.example.com"
modules_enabled = {
  "ping";
}
authentication = "internal_plain"

Here are the jicofo and jibri logs:
masked_jicofo.log.txt (211.3 KB)
masked_log.0.txt (3.3 KB)

@damencho I was just testing live streaming on https://beta.meet.jit.si/NuclearAgendasTestifyCompletely and it also immediately fails to send stream there. Coincidence? Is some else facing this issue?

I don’t think we have any streamers on beta at the moment…

Was your jibri free when you tried it? Maybe someone else was using it if you are having just one instance of it.

Thanks for the quick reply!
Yes it was free. The logs have busyStatus=IDLE. Do you see anything suspicious in the log/conf files I attached?

I saw the error:

Jicofo 2021-06-09 08:51:43.438 SEVERE: [15] [type=jibri brewery=jibribrewery] BaseBrewery.start#176: Failed to create room.
org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.jitsi.example.com: XMPPError: remote-server-not-found - cancel. Generated by auth.jitsi.example.com

You have error in your config it should be:
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.jitsi.example.com

1 Like

I feel silly. Thanks a lot for pointing it out! :raised_hands:

No worries :slight_smile: