Jibri error java.lang.IllegalStateException:

The following error occurs after jibri installation:

jibri log:

SCHWERWIEGEND: [48] org.jitsi.jibri.api.xmpp.XmppApi.run() Error starting Jibri service : java.lang.IllegalStateException: The path to the driver executable must be set by the webdriver.chrome.driver sys$
com.google.common.base.Preconditions.checkState(Preconditions.java:754)

Installation was performed as per instruction video

Thanks for advice!

Looks like chromedriver isn’t installed or is installed to a nonstandard location. Can you run which chromedriver as the jibri use in the terminal and paste what you get?

Good morning, thanks for your reply!
logged in as root:
root@jibri:/home/toni# which chromedriver
/usr/local/bin/chromedriver

logged in as jibri or any other user: nothing…

Thank you in advance for your reply!
Regards, Toni

The default location of chromedriver (where Jibri looks for it) is in /usr/bin, I believe. I’d try sym-linking the one you have in /usr/local/bin to there.

Good evening,
thank you for your early reply. Setting the symlink and setting chmod to allow all users to execute chromedriver, two other errors occurred, please see below:

20:38:35.031 SCHWERWIEGEND: [49] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load

and

20:38:35.496 SCHWERWIEGEND: [49] org.jitsi.jibri.service.impl.FileRecordingJibriService.finalize() Failed to run finalize script: java.io.IOExcep$
java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)

Thank you in advance for your reply

Best regards
Toni

20:38:35.031 SCHWERWIEGEND: [49] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load

This means Jibri couldn’t access your Jitsi meet server. Have you verified it’s accessible from the Jitsi machine?

20:38:35.496 SCHWERWIEGEND: [49] org.jitsi.jibri.service.impl.FileRecordingJibriService.finalize() Failed to run finalize script: java.io.IOExcep$
java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)

This means there was an issue with the finalize script. Maybe it wasn’t there or doesn’t have execute permissions? (I think the other logs around that error may give more info).

Hello,
first thank you for your advices. The symlink did not work. After a complete new install the chromedriver still was not found. An install script I found:


made the chromedriver working.
Adding the line: “consider_bosh_secure = true;” into the prosody.config finally solved another error “recording failed to start”

The “finalize_recording.sh” was added and jibri works now.

Thank you once more for your patience!
Regards Toni