Jibri does not record more than 30 seconds

Hello, I am recording meetings with jibri, but they are not being recorded complete, when viewing the video it only lasts between 30-45 seconds, and it was recorded for more than 1 minute, is there any parameter to configure the limit or which log can I review?

image

image

final file video
image

What are the specs (CPU, RAM) of your jibri server?

6 CPU
image

12GB RAM

That should be fine. What else do you have hosted on the server besides Jibri?
Share your ffmpeg log.

Only Jibri, attached log ffmpeg
ffmpeg.0.txt (1.6 MB)

Yeah, the server is not powerful enough - your ffmpeg log shows that. You need a more powerful server.
Is it a virtual server? CPU cores vary in strength, so even with the same number of cores, performance could be different.

yes it’s a virtual server,

now it crashes at 3 minutes, log.0 show
"o Error: QuitUnexpectedly SESSION [alsa @ 0x55f999c8f240] ALSA buffer xrun.
2023-01-18 00:05:50.633 INFO: [63] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() File recording service transitioning from state Running to Error: QuitUnexpectedly SESSION [alsa @ 0x55f999c8f240] ALSA buffer xrun.
2023-01-18 00:05:50.913 INFO: [63] org.jitsi.jibri.api.xmpp.XmppApi.log() Current service had an error Error: QuitUnexpectedly SESSION [alsa @ 0x55f999c8f240] ALSA buffer xrun., sending error iq
2023-01-18 00:05:51.194 FINE: [63] org.jitsi.jibri.statsd.JibriStatsDClient.log() Incrementing statsd counter: stop:recording
2023-01-18 00:05:51.299 INFO: [63] org.jitsi.jibri.JibriManager.log() Stopping the current service
2023-01-18 00:05:51.310 INFO: [63] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Stopping capturer
2023-01-18 00:05:51.318 INFO: [63] org.jitsi.jibri.util.JibriSubprocess.log() Stopping ffmpeg process
2023-01-18 00:05:52.624 INFO: [63] org.jitsi.jibri.util.JibriSubprocess.log() ffmpeg exited with value 137
2023-01-18 00:05:52.625 INFO: [63] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Quitting selenium"

As @Freddie said, you don’t have enough CPU power. You need a dedicated CPU, not a shared one…

You can also try reducing the resolution. I see currently it’s 720p, which should be OK for a virtual machine with 6cpu and 12ram, but I guess the reason is that the host machine is not very powerful.

You can either get a stronger VM (or use a dedicated) or reduce the resolution - in jibri.conf and in xorg-video-dummy.conf (in section “Screen”); then restart jibri and jibri-xorg

720p is HD, a lower option is for example SD (Standard Definition), 480p - 640x480. Maybe it can help, if changing the server is not an option for you.

hi thanks, it’s work with 640x480, but now show this message

how could remove

very thanks for help

You could be hitting this: Meeting name should not contain any of these characters · Issue #1293 · jitsi/docker-jitsi-meet · GitHub

I haven’t faced this problem, in the github issue the reporter says that on some other resolutions there is no such problem. Maybe you can try some of the resolutions that do work - they are in the last comments of the issue.

My wild guess is that this can have something to do with the aspect ratio - the default ones in Jibri are 16:9 (1280x720, 1920x1080) and 640x480 is a 4:3 ratio.

You can try one of these resolutions 16:9 aspect ratio - Wikipedia

I’m sorry I can’t be more specific, but I hope this helps.