Jibri does not authenticate or register if i set a password for the room

Hi,
i have implemented jibri servers. Registration works if the room has no password.

If i set a password in the room, registration does not start!

What should i change?

Thanks

This is a known limitation, but there are a couple of posts here offering a suitable workaround. Do a quick search in the forum for those threads.

I found this post: Jibri - Authenticating if a room has a password added by moderator

I read the post and try with the test VMs.

But… will this problem be solved?

Thank you

Hi,
I created my module in / usr / share / jitsi-meet / prosody-plugins and named it mod_allow_jibri_bypass.lua

Inside the file i wrote:

local MUC_NS = "http://jabber.org/protocol/muc";
local jid = require "util.jid";
local jibri_user = os.getenv("JIBRI_RECORDER_USER")
local jibri_domain = os.getenv("XMPP_RECORDER_DOMAIN")

module:hook("muc-occupant-pre-join", function (event)
    local room, stanza = event.room, event.stanza;

    local user, domain, res = jid.split(event.stanza.attr.from);
    log("info", "--------------> user %s domain %s res %s pass %s", tostring(user),tostring(domain),tostring(res),tostring(room:get_password())); 
    
    if ( user == "recorder" and domain == "recorder.conference2.mydom.local" ) then
      local join = stanza:get_child("x", MUC_NS);
      join:tag("password", { xmlns = MUC_NS }):text(room:get_password()); 
    end;
end);

In my /etc/prosody/conf.d/conference2.mydom.local.cfg.lua file i wrote:

Component "conference.conference2.mydom.local" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        "allow_jibri_bypass";
        -- "token_verification";
    }

I restart the service prosody but it goes wrong, failed.

Where am i wrong?

thanks

1 Like

Hi,
I solved.

I was wrong to write the configuration in the cfg.lua file.

Bye…