Jibri authentication (ldap o internal)

Hello, I am using LDAP to authenticate users to the primary domain, I also have the anonymous domain enabled for users who want to join without authenticating. It works perfect, I even ask for the username for whoever joins the room.
However when installing jibri, I can’t get it to work with internal authentication or ldap authentication.

Try creating the following users:

prosodyctl register jibri auth.yourdomain.com 11111P@00000
prosodyctl register recorder recorder.yourdomain.com 111111P@000000

no problem using “@” in the password?

in /etc/prosody/prosody.cfg.lua add:

Component "internal.auth.yourdomain.com" "muc"
    modules_enabled = {
      "ping";
    }
    storage = "internal"
    muc_room_cache_size = 1000
VirtualHost "recorder.yourdomain.com"
  modules_enabled = {
    "ping";
  }
  authentication = "internal_plain"

In /etc/jitsi/jicofo/sip-communicator.properties add:

org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.yourdomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

the file with all the lines is:

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.yourdomain.com
org.jitsi.jicofo.auth.URL=XMPP:yourdomain.com
Org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.yourdomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

In /etc/jitsi/meet/yourdomain-config.js enable these options:

fileRecordingsEnabled: true, // If you want to enable file recording
liveStreamingEnabled: true, // If you want to enable live streaming
hiddenDomain: 'recorder.yourdomain.com',

in /etc/jitsi/jibri/config.json changes to:

        "xmpp_server_hosts": [
            "yourdomain.com"
        ],
        "xmpp_domain": "yourdomain.com",
        "control_login": {
            "domain": "auth.yourdomain.com",
            "username": "jibri",
            "password": "11111P@00000"
        },
        "control_muc": {
            "domain": "internal.auth.yourdomain.com",
            "room_name": "JibriBrewery",
            "nickname": "jibri"
        },
        "call_login": {
            "domain": "recorder.yourdomain.com",
            "username": "recorder",
            "password": "111111P@000000"
        },

i am not using jigasi, restart the services and even restart the server.

Someone could help me? what i need is for jibri to authenticate with the users created with prosody or with ldap (user created in the domain for that function)
Regards

I could solve this topic leaving the 2 types of login

     authentication = "internal_hashed"
     authentication = "ldap2"