Jibir is not recording when

Hello,

Jibri is unable to record when prejoinPageEnabled: true, in config.js. I tried to enable below to bypass that but issue still persists. Can I know what is the fix you have applied for this?

p2p: {
// Enables peer to peer mode. When enabled the system will try to
// establish a direct connection when there are exactly 2 participants
// in the room. If that succeeds the conference will stop sending data
// through the JVB and use the peer to peer connection instead. When a
// 3rd participant joins the conference will be moved back to the JVB
// connection.
enabled: false,

@damencho cho

regards
Swathi

What Jibri version are you using? Jibri should be bypassing the prejoin page already: https://github.com/jitsi/jibri/blob/master/src/main/kotlin/org/jitsi/jibri/selenium/JibriSelenium.kt#L107

Also, what you’ve disabled there is p2p mode, which is something different.

Also, attach some Jibri logs from when it happens

@bbaldino

Thank you for the response, I am using containers . The change you mentioned above has to done on jibri or web config.js.

I will update the logs in a while.

Regards
Swathi

@bbaldino

I am using this repo for Jibri -

This will remove ALSA and use pulseaudio.

I have deployed this jar with kubernetes HPA and not sure the above changes can be applied here directly since it is a jar file for jibri.

regards
Swathi

This change is in Jibri