Jibi - video with gray canvas

Hello friends, I have an intriguing problem.

I managed to get 2 Jibris instances to run on a separate server from my Jitsi installation.

Server 1 (jitsi.mydomain.com)
Server 2 (jibri.mydomain.com)

However, when starting a recording, the generated video file is just a screen with the text “Fellow Jister”

I don’t have authentication configured, the rooms are open, do I need to activate it to have successful recording?

Another note is that when running the command:

sudo prosodyctl check config

I get the following output

**************************
Prosody was unable to find lua-unbound
This package can be obtained in the following ways:

  Debian/Ubuntu | sudo apt install lua-unbound
       luarocks | luarocks install luaunbound
         Source | https://www.zash.se/luaunbound.html

Old DNS resolver library will be used
More help can be found on our website, at https://prosody.im/doc/depends
**************************

Checking config...

    You have some obsolete options you can remove from the global section:
    cross_domain_bosh

    Your configuration contains the following unreferenced components:

        internal.auth.mysite.com.br

    Clients may not be able to discover these services because they are not linked to
    any VirtualHost. They are automatically linked if they are direct subdomains of a
    VirtualHost. Alternatively, you can explicitly link them using the disco_items option.
    For more information see https://prosody.im/doc/modules/mod_disco#items
Done.

Problems found, see above.

My Server:
Ubuntu 18.04

Tutorial:

Since you can get the conference room screen, there shouldn’t be an authentication issue.

Thanks for your attention friend.

Do you have any idea what it could be? the Prosody? any sound interface? any idea would help me

Can you create a working conference room with 3 participants?

I’ll try. I tried to record with only 1 person in the room

Hello, I started a meeting with 2 Participants and started a recording.

The image is attached is just a theme with the names of the users, I had the camera and the sound on.

However, the second person in the meeting stopped hearing and seeing me as soon as I started recording and when I finished recording the person was able to hear and see me normally again.

There is nothing wrong with the Jibri and Jitsi logs.

But when I run the command

sudo prosodyctl check config

I receive this.


**************************
Prosody was unable to find lua-unbound
This package can be obtained in the following ways:

  Debian/Ubuntu | sudo apt install lua-unbound
       luarocks | luarocks install luaunbound
         Source | https://www.zash.se/luaunbound.html

Old DNS resolver library will be used
More help can be found on our website, at https://prosody.im/doc/depends
**************************

Checking config...

    You have some obsolete options you can remove from the global section:
    cross_domain_bosh

    Your configuration contains the following unreferenced components:

        internal.auth.mysite.com.br

    Clients may not be able to discover these services because they are not linked to
    any VirtualHost. They are automatically linked if they are direct subdomains of a
    VirtualHost. Alternatively, you can explicitly link them using the disco_items option.
    For more information see https://prosody.im/doc/modules/mod_disco#items
Done.

Problems found, see above.

Is there a correlation?

Seems like a UDP/10000 issue. Did you check a conference with 3 participants?