Javascript files load too slow also can't cache them

Hi, done a clean quick install an hour ago. Everything is great, except one problem. Welcome page and room pages are loading too slow. Upon further inspection i realized that lib-jitsi-meet.min.js and app.bundle.min.js takes forever too load, 15 seconds and 45 to 60 seconds respectively.

Tried a bunch of nginx server/client side cache methods but nothing works, whatever i do the request headers of those js files are always “pragma no-cache”.

How do fix this problem?

Thanks in advance.

2 Likes

I have the same. this happen after configure jifoco i think. Before intstall jicofo everthing fast loding. now i need 7-8 second to page show up:

image

My java version:
image

The problem is with content download time, i don know why:
image

@damencho Can you check this issue ?

Hello,
I have the same issue too, any help?

Hello,
Enabling GZIP on Nginx fixed the issue for me.

I did enable GZIP but no change. Care to share your config?

Yes sure,
On nginx.conf file:

gzip on;
gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

I have the same. Gzip made some little improvement but is still takes to load home page more than 30 sec. usually.

Yeah didn’t change much for me either. Funny thing is when i connect to a browser vpn, the page loads instantly. But from my home network it takes about a minute. I don’t really understand.

I stoped all Jitsi components Jicofo JVB and Prosody but same. I guess it is all about network i.e. routing, forwarding, parcel lost etc.

I am running Jitsi in a VM on my laptop using home use modem as a router. My set up is prone to network issues.

We have 2 more on the same server almost same configs etc. everythinh is the same except this slow one is the latest package with jvb2. The others run just fine and fast.

But jvb has nothing to do with the delivery of javascript code, doesn’t it?

How do you maesure this? Do you use the web developer tools of your browser? Did you maybe forget to uncheck ‘Disable cache’?

No it doesn’t, i mentioned it to tell that i have problems with the latest jitsi-meet package.

This issue started appearing on my instance as well, pretty much out of the blue. This started today, yesterday everything was still fine.
Gzip improves it a little, but I still have load times of ~9 seconds which is insane.

Did a new installation on a different machine with same specs everything is literally the same and this time the pages load very fast. There should be a small thing that i’m missing but can’t find it…

I had the same issue loading jitsi on my deployment. Upon inspection found that lib-jitsi-meet.min.js and app.bundle.min.js take forever to load. I tried adding the two JS files to S3 and it’s loading fast now.

+1! gzip improved a little, but it still takes quite some time. I don’t have any bottlenecks RAM/CPU-wise. Keeping an eye on this thread.

gzip is now enabled in nginx in master.

Just add google analytic Id in config.js and save it. You will get faster loading your jisti welcome page.