java.nio.BufferOverflowException at java.nio.HeapByteBuffer.put(HeapByteBuffer.java:189) when starting transcription

jigasi

#1

Hi again

I am having some issues when running APP.conference._room.dial (“jitsi_meet_transcribe”) on my installation. Jigasi connects successfully but gives the following error:

   2018-10-03 08:52:21.145 INFO: [111] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().263 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 2528857923 video: null
java.nio.BufferOverflowException
	at java.nio.HeapByteBuffer.put(HeapByteBuffer.java:189)
	at java.nio.ByteBuffer.put(ByteBuffer.java:859)
	at org.jitsi.jigasi.transcription.Participant.buffer(Participant.java:557)
	at org.jitsi.jigasi.transcription.Participant.giveBuffer(Participant.java:513)
	at org.jitsi.jigasi.transcription.Transcriber.bufferReceived(Transcriber.java:620)
	at org.jitsi.impl.neomedia.device.AudioMixerMediaDevice$2.read(AudioMixerMediaDevice.java:397)
	at org.jitsi.impl.neomedia.conference.AudioMixerPushBufferStream.readInPushBufferStream(AudioMixerPushBufferStream.java:594)
	at org.jitsi.impl.neomedia.conference.AudioMixerPushBufferStream.readInPushBufferStreams(AudioMixerPushBufferStream.java:787)
	at org.jitsi.impl.neomedia.conference.AudioMixerPushBufferStream.read(AudioMixerPushBufferStream.java:465)
	at org.jitsi.impl.neomedia.conference.AudioMixerPushBufferStream.transferData(AudioMixerPushBufferStream.java:1174)
	at org.jitsi.impl.neomedia.conference.AudioMixerPushBufferStream$1.transferData(AudioMixerPushBufferStream.java:132)
	at org.jitsi.impl.neomedia.protocol.StreamSubstituteBufferTransferHandler.transferData(StreamSubstituteBufferTransferHandler.java:91)
	at org.jitsi.impl.neomedia.device.AudioSilenceCaptureDevice$AudioSilenceStream.run(AudioSilenceCaptureDevice.java:294)
	at java.lang.Thread.run(Thread.java:748)

Which keeps looping infinitely unless I stop jigasi. I tried to run the same version on the apt-get version in a different server and it ran as expected. The code I am using to build jigasi is the same as the one from github without any changes. I tested on different machines and it gives the same error for all of them.

Regards


#2

I haven’t seen this issue and I’m not sure what can be the problem … That is strange. Are you starting the one from source and the one from the package with same configuration and same java version running it?


#3

Solved. It was actually a mismatch between the java versions, for some reason my script was installing jre 1.10 and building on jdk 1.8.

in case someone had similar problems, jigasi was not running against java 1.10 or 1.11, downgrading to 1.8 worked.

Thanks as aways.


#4

Thanks for the update