JaaS / Jitsi-meet Chrome issue (Meet not launching)

Running into an issue ONLY on Chrome (initially with JaaS, but occurs on any Jitsi Meet instance, including one-off meet.jit.si test meetings) where the Meet iframe does not properly load. Specifically, it looks like the div id=“react” tag is empty, whereas testing on Firefox/Safari shows that div is populated with the meeting content.

Console shows consistent js errors on Chrome that are not there in a working meeting on Firefox/Safari:

TypeError: Cannot read property 'catch' of undefined
    at componentDidMount (Video.js:206)
    at vl (react-dom.production.min.js:251)
    at t.unstable_runWithPriority (scheduler.production.min.js:18)
    at Vr (react-dom.production.min.js:120)
    at yl (react-dom.production.min.js:244)
    at il (react-dom.production.min.js:223)
    at react-dom.production.min.js:121
    at t.unstable_runWithPriority (scheduler.production.min.js:18)
    at Vr (react-dom.production.min.js:120)
    at Kr (react-dom.production.min.js:121)
    at Gr (react-dom.production.min.js:120)
    at el (react-dom.production.min.js:214)
    at Object.enqueueSetState (react-dom.production.min.js:133)
    at APP.k.setState (react.production.min.js:13)
    at BaseApp.js:241
    at new Promise (<anonymous>)
    at APP._navigate (BaseApp.js:240)
    at middleware.js:149

Subsequent js errors occur with long stack traces (next one starts with TypeError: Cannot read property ‘name’ of undefined at Function.mapToProps (AbstractChat.js:111)).

Chrome version is Version 91.0.4472.77 (Official Build) (x86_64)

As mentioned this occurs on meet.jit.si itself, and I assume Jitsi software there is fully up to date. No https errors (and camera and mic permissioned normally).

First noticed this today after having Chrome work without issues previously. Reproduced on multiple MacOS devices (including Big Sur version and an earlier version). Have not had the issue on iOS Chrome.

Any ideas on what could be causing this? Anything with version 91 of Chrome? Happy to provide more stack traces if it helps.

Resolved - turns out it was a browser extension that must have had recent updates to bring it in conflict. Tried in incognito, worked, then disabled the extension it’s working again. Disregard!

Nice troubleshooting and thank you for updating this thread with the solution !! Please let us know if you stumble upon any other issues.