Issues between Jitsi docker & Nginx container

Hi,

I have been struggling with this issue this week and to be honest I don’t know what to test anymore. Any clue what would be more than welcome.

I’ve configured an structure like this one:

image

I got every container up and running but I am not able to access to my jitsy web site.

I leave bellow my nginx configuartion:
server {
if ($host = meet.example.com) {
return 301 https://$host$request_uri;
} # managed by Certbot

server_name meet.example.com;
listen 80;
return 404; # managed by Certbot

}

server {
listen [::]:443 ssl;
listen 443 ssl;

server_name meet.example.com;

server_tokens off;
access_log  /var/log/nginx/meet.example.com.access.log;
error_log   /var/log/nginx/meet.example.error.log error;

location / {
    proxy_pass http://localhost:8000;
    proxy_set_header Host $host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
}
location /xmpp-websocket {
    proxy_pass http://127.0.0.1:5280;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
}
location /colibri-ws {
    proxy_pass http://127.0.0.1:10000;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
}
ssl_certificate /etc/letsencrypt/live/example.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/example.com/privkey.pem;

}

Regarding compose, only thing it was modify is web https port as we are using host netowork and it was taken:
web:
image: jitsi/web:${JITSI_IMAGE_VERSION:-stable}
restart: ${RESTART_POLICY:-unless-stopped}
ports:
- ‘${HTTP_PORT}:8000’
- ‘${HTTPS_PORT}:4433’

Thank you in advance,
Diego

In this setup I’d disable HTTPS in the Jitsi container and proxy the entire subdomain (not individual routes) to the Jitsi container. SNI should work here.

Hi Saghul,

HHTTPS is disabled in the jitsi contaianer via env. I think is somthing on the proxi conf but I can find where the problem is.

Thanks,