Issue with version 2.0.7648

Hi,

I have used jitsi version 2.0.7439 and it was working completely fine.
but recently I have updated to version 2.0.7648 and I am getting “not allowed error” with jwt token based authentication.
this is the prosody error I am getting -
prosody_1 | muc.meet.jitsi:token_verification error Token eyJhbGciOiJSUzI1NiIsInR5cCIgOiAiSldUIiwia2lkIiA6ICJ4NzFGeXBSWHF5YjJTMGNoOE9UQ3hKUTZNT2xXZGdIOVVsNVBtNzZadkJnIn0.eyJleHAiOjE2NjMzNDIyNzcsImlhdCI6MTY2MzM0MTk3NywiYXV0aF90aW1lIjoxNjYzMzQxOTA2LCJqdGkiOiJiODBhNGFiNC1mMWIwLTRjYjAtYjEwZC1iZTU0ZDcyNzVjZDQiLCJpc3MiOiJodHRwczovL2Rldi1zc28udGF0YW1kLmNvbS9yZWFsbXMvVUNhcmUiLCJhdWQiOiJWQy1qaXRzaSIsInN1YiI6ImE4YTRiMTY1LTRkNjgtNGUxNi1iNjAxLTNjMWNkY2Y5NGZhOCIsInR5cCI6IkJlYXJlciIsImF6cCI6IlZDLWppdHNpIiwibm9uY2UiOiI2MTE4ZWE2NC1kYjlmLTRjMDEtODZjMi1jYjJmNDhlZWE2YzEiLCJzZXNzaW9uX3N0YXRlIjoiYTdmOTc3ZjgtNWMxZi00N2NkLWIzODAtZGE5Y2NkYThmYmEzIiwiYWNyIjoiMCIsImFsbG93ZWQtb3JpZ2lucyI6WyIqIl0sInNjb3BlIjoib3BlbmlkIGVtYWlsIHByb2ZpbGUiLCJzaWQiOiJhN2Y5NzdmOC01YzFmLTQ3Y2QtYjM4MC1kYTljY2RhOGZiYTMiLCJlbWFpbF92ZXJpZmllZCI6dHJ1ZSwiY29udGV4dCI6eyJ1c2VyIjp7Im5hbWUiOiJBYmhpc2hlayIsImlkIjoiYThhNGIxNjUtNGQ2OC00ZTE2LWI2MDEtM2MxY2RjZjk0ZmE4IiwiYXZhdGFyIjoiaHR0cHM6Ly93d3cuZ3JhdmF0YXIuY29tL2F2YXRhci84ZTMxNmY1NzdhZmZkZGRkMGNlZDM1ZWE4MTM3MzMzYiIsImVtYWlsIjoiYWJoaXNoZWsudmlqYXl2YXJnaXlhQHRhdGFtZC5jb20ifX0sIm5hbWUiOiJBYmhpc2hlayBWaWpheXZhcmdpeWEiLCJwcmVmZXJyZWRfdXNlcm5hbWUiOiJhYmhpc2hlayIsImdpdmVuX25hbWUiOiJBYmhpc2hlayIsImZhbWlseV9uYW1lIjoiVmlqYXl2YXJnaXlhIiwiZW1haWwiOiJhYmhpc2hlay52aWpheXZhcmdpeWFAdGF0YW1kLmNvbSIsInJvb20iOiIqIn0.OMQQrLBjfCIl6Bhr9guHGkTUSB0eWomMLCwNsIBhmSgCSIInRm8oZznkVhrhnRdGeMjRUL0AOR9N4EX6VEx2oJdlcel5fhAM9fAcC4pBJsojMO6LL5VLg3UTVQp57SAsKrwg4X8RHpx6dWM8WD4wXcqwkclNz8TAekrrGTy2-xyriVb1UDxP1vGkoIqtxxUNZzewDFuHVCi2Q0Huu00OEpuARflOKs3AO4muBKfYcR7Ypj2NCXgx8ZfquoUVsaeXUgr1KiMqPuWFLZ9_Eu_aTDSA2oeUUIhFZgPm6zVGg9PfMmAO3ZUY4P3mkjpJI9Dp_8jK82v7ClnpX6jCypmObQ not allowed to join: romanticretailscampaignadorably@muc.meet.jitsi/3d408fcc

Even though I have used room : “*” in my token but still not able to join.
Any help ?

Try setting enable_domain_verification = false in prosody config, or fix token payload so “sub” matches the server domain (you can also set "sub": "*").

The default changed from false to true in version 7530 (commit).

2 Likes

thanks Shawn