Issue with setting up Jigasi transcription

Hello I am trying to set up a test instance of jitsi with transcription support. I have successfully set up jitsi in AWS EC2 instance, but I can’t make jigasi transcription to work. My biggest issue is that I can’t find any hints in the logs. The only visible symptom is the chrome console error when executing
APP.conference._room.dial("jitsi_meet_transcribe")
I receive feature-not-implemented error:

Logger.js:154 2020-04-01T11:21:40.117Z [modules/xmpp/strophe.rayo.js] Dial error  <iq xmlns=​"jabber:​client" type=​"error" to=​"0342091b-c321-461e-bd65-a6ac3588028b@18.197.10.61/​f6ee9fb8-1d15-4c7b-9d95-3d130420b128" from=​"test@conference.18.197.10.61/​focus" id=​"966d338e-e44c-464d-8967-7adefa79a47f:​sendIQ">​…​</iq>​
VM54 react_devtools_backend.js:6 2020-04-01T11:21:40.137Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>:  UnhandledError: null Script: null Line: null Column: null StackTrace:  <iq xmlns=​"jabber:​client" type=​"error" to=​"0342091b-c321-461e-bd65-a6ac3588028b@<SERVER_IP>/​f6ee9fb8-1d15-4c7b-9d95-3d130420b128" from=​"test@conference.<SERVER_IP>/​focus" id=​"966d338e-e44c-464d-8967-7adefa79a47f:​sendIQ">​<error type=​"cancel">​<feature-not-implemented xmlns=​"urn:​ietf:​params:​xml:​ns:​xmpp-stanzas">​</feature-not-implemented>​</error>​</iq>​

please find logs and configuration shared here (as I can’t upload files to this post): https://drive.google.com/drive/folders/19kEkP4gKGs9vTlw8MhF85p9kjgrt6ldH?usp=sharing
.

I have set up Jigasi sip-configuration to enable transcription and have installed gcould and added google credentials json path in jigasi config.

I will be grateful for any hits on how to resolve this issue.

Thank you in advance

What makes me wonder is this snippet <SERVER_IP>. I expect to see something like jitsi.domain.tld?
As in jigasi-sip-communicator.properties you should have something like:

org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=jitsi.domain.tld

And i don’t see any configured XMPP-Account for your Jigasi, what would be like and begin with:

# XMPP account used for control

net.java.sip.communicator.impl.protocol.jabber.acc1=acc1
[...]

These lines look like this (in this case from a docker-setup):

Ciao,

grex

Hi Grex,

Thank you for looking into it. As for <SERVER_IP> I have replaced actual server IP with this snippet in the logs, as I was setting the server up on a AWS EC2 without any domain or proper network configuration. I should’ve stated that implicitly.

As for XMPP, I am not using authenticated login, my sip-comunicator.properties have this set up:

I am not using the docker setup, I have installed jitsi on Ubuntu 18.04 LTS EC2 instance directly.

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
org.jitsi.jigasi.xmpp.acc.JINGLE_NODES_ENABLED=false
org.jitsi.jigasi.xmpp.acc.IM_DISABLED=true
org.jitsi.jigasi.xmpp.acc.SERVER_STORED_INFO_DISABLED=true
org.jitsi.jigasi.xmpp.acc.IS_FILE_TRANSFER_DISABLED=true

I will take a look at a docker configuration, thank you.

I just meant the docker-conf as an example for the properties-file, was not expecting that you use actually docker.

My setup was, that i added an jigasi-Xmpp-Account on the Server (jigasi@auth.domain.tld) and added those credentials in the file. So you have maybe a different approach, which i have no experience with.
And i’m even not sure if this whole thing works without an DNS-resolvable Domain?