Issue with secure domain function of newly installed JM (stable and nightly)

Okay, something else is going on with your Jitsi installation then. Can you share your jicofo and prosody logs?

in prosody.log one error is blowing up the whole file (> 6Mb):
Client connected
Dec 15 20:53:36 c2s55d9425c3e30 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:53:41 c2s55d9424760b0 info Client connected
Dec 15 20:53:41 c2s55d9424760b0 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:53:46 c2s55d942289c60 info Client connected
Dec 15 20:53:46 c2s55d942289c60 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:53:51 c2s55d9423b46e0 info Client connected
Dec 15 20:53:51 c2s55d9423b46e0 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:53:56 c2s55d942853260 info Client connected
Dec 15 20:53:56 c2s55d942853260 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:54:01 c2s55d9422cf4a0 info Client connected
Dec 15 20:54:01 c2s55d9422cf4a0 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:54:06 c2s55d9419b4940 info Client connected
Dec 15 20:54:06 c2s55d9419b4940 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown
Dec 15 20:54:11 c2s55d941dc0690 info Client connected
Dec 15 20:54:11 c2s55d941dc0690 info Client disconnected: ssl handshake error: sslv3 alert certificate unknown

Did you install a Letsencrypt certificate?

yes

found something “severe” in jicofo.log

Jicofo 2020-12-15 20:55:14.139 SEVERE: [17] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: The following addresses failed: ‘localhost:5222’ failed because: localhost/127.0.0.1 exception: java.net.ConnectException: Connection refused (Connection refused), localhost/0:0:0:0:0:0:0:1 exception: java.net.ConnectException: Connection refused (Connection refused)
org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘localhost:5222’ failed because: localhost/127.0.0.1 exception: java.net.ConnectException: Connection refused (Connection refused), localhost/0:0:0:0:0:0:0:1 exception: java.net.ConnectException: Connection refused (Connection refused)
at java.lang.Thread.run(Thread.java:748)

Jicofo 2020-12-15 21:06:43.021 SEVERE: [1] org.jitsi.jicofo.Main.log() An uncaught exception occurred in thread=Thread[main,5,main]

java.lang.ClassCastException: org.jitsi.jicofo.auth.XMPPDomainAuthAuthority cannot be cast to org.jitsi.jicofo.auth.ShibbolethAuthAuthority

at org.jitsi.jicofo.rest.Application.(Application.java:51)

at org.jitsi.jicofo.JicofoServices.(JicofoServices.kt:85)

at org.jitsi.jicofo.Main.main(Main.java:90)

Jicofo 2020-12-15 22:35:39.735 INFO: [1] JitsiConfig.log() Initialized newConfig: merge of /etc/jitsi/jicofo/jicofo.conf: 1,system properties,reference.conf @

at java.lang.Thread.run(Thread.java:748)

Jicofo 2020-12-15 22:35:41.715 SEVERE: [1] org.jitsi.jicofo.Main.log() An uncaught exception occurred in thread=Thread[main,5,main]

java.lang.ClassCastException: org.jitsi.jicofo.auth.XMPPDomainAuthAuthority cannot be cast to org.jitsi.jicofo.auth.ShibbolethAuthAuthority

at org.jitsi.jicofo.rest.Application.(Application.java:51)

at org.jitsi.jicofo.JicofoServices.(JicofoServices.kt:85)

at org.jitsi.jicofo.Main.main(Main.java:90

I’m reading over the thread and I see you mentioned having problems with certificates earlier. It seems to me you may have multiple problems with this installation. Ideally, you want to test to make sure 2 and 3 participant calls go through successfully right after installing Jitsi before moving on to other things (secure domain, Jibri e.t.c…)

At this point, there are two options:

  1. Keep trying to figure out what the problem(s) is/are
  2. Purge and reinstall

Personally, when things start going crazy, I simply just purge and reinstall, but it’s my personal preference.

If you choose to purge and reinstall (should only take a few minutes), you can run the following commands:

  1. sudo apt-get purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-web jicofo jitsi-videobridge2

  2. sudo apt-get install jitsi-meet

  3. sudo dpkg-reconfigure jitsi-videobridge2
    (Select the domain)

  4. sudo dpkg-reconfigure jitsi-meet-web-config
    (Select LetsEncrypt cert)

  5. sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

I agree, that this would be the most easy and straight forward.

one last question: to preinstall java 8 before jitsi meet installation (which is now part of the jitsi handbook but I cannot remember that I did Java preinstall ever on a new server droplet) or default-jre?

MANY thanks for your help and time!
kind regards, MS

you are trying to install the unstable version of Jitsi. Usually the ‘unstable’ version is in fact very stable. But at the moment it’s really not stable: jicofo 1.0-684-1 can’t work unless you setup shibboleth, an experience best kept for computer professionals. If you reinstall, use stable version instead. Or wait until the unstable version is fixed.

Ok, I will start from scratch with stable version, probably easier…

What is this? What is the problem you are refurring to?

Dear All,
After purge and reinstall the server is again back to normal.
Thx again to Freddie!

best regards, MS

Glad to hear! :+1:t5:

Dankeschön hat mir sehr geholfen