Issue with jitsi-videobridge after a fresh install today

Hi Everyone,

I installed Jitsi on a new server today and once finished can’t have any meeting which is related to jitsi-videobridge not being running by default.

Looking at /etc/init.d there is no jitsi-videobridge but I have jitsi-videobridge2.

I tried serice restart for jitsi-videobridge2 and it worked but after rebooting the machine even restarting the service does not seems to be helping.

It shows Unforgettably something went wrong error when starting any meeting.

I had another setup last week as test and it was using jitsi-videobridge only and did not have such issues.

Any idea?

Is there anything relevant in your jvb log? What is the status of jitsi-videobridge2?

] Videobridge.createConference#326: cre‐
ate_conf, id=3177df3f5055835f gid=null logging=false 2020‐04‐03
08:51:14.957 INFO: [17] Health.doRun#294: Performed a successful
health check in 9ms. Sticky failure: false 2020‐04‐03
08:51:24.957 INFO: [17] Videobridge.createConference#326: cre‐
ate_conf, id=962ff75fbb8670cd gid=null logging=false 2020‐04‐03
08:51:24.963 INFO: [17] Health.doRun#294: Performed a successful
health check in 6ms. Sticky failure: false

This is the log after voicebridge2 restart

2020-04-03 08:56:02.689 INFO: [11] LegacyConfigFileLoader$Companion.load#40: Attempting to load legacy config file at path /etc/jitsi, videobridge, sip-communicator.properties
2020-04-03 08:56:02.689 INFO: [11] LegacyConfigFileLoader$Companion.load#40: Attempting to load legacy config file at path /etc/jitsi, videobridge, sip-communicator.properties
2020-04-03 08:56:02.808 INFO: [11] OctoRelayService.start#62: Octo relay is disabled.
2020-04-03 08:56:02.927 INFO: [21] org.ice4j.ice.harvest.StunMappingCandidateHarvester.discover: Discovered public address 13.237.23.16:44280/udp from STUN server 13.237.235.12:443/udp using local address 172.31.8.200:0/udp
2020-04-03 08:56:02.927 INFO: [20] org.ice4j.ice.harvest.MappingCandidateHarvesters.initialize: Using org.ice4j.ice.harvest.StunMappingCandidateHarvester, face=/172.31.8.200, mask=/13.237.23.16
2020-04-03 08:56:02.927 INFO: [20] org.ice4j.ice.harvest.MappingCandidateHarvesters.initialize: Initialized mapping harvesters (delay=204ms). stunDiscoveryFailed=false
2020-04-03 08:56:02.930 INFO: [17] org.ice4j.ice.harvest.AbstractUdpListener.: Initialized AbstractUdpListener with address 172.31.8.200:10000/udp. Receive buffer size 10485760 (asked for 10485760)
2020-04-03 08:56:02.934 INFO: [17] org.ice4j.ice.harvest.SinglePortUdpHarvester.: Initialized SinglePortUdpHarvester with address 172.31.8.200:10000/udp
2020-04-03 08:56:04.028 INFO: [22] [hostname=localhost id=shard] MucClient$1.connected#266: Connected.
2020-04-03 08:56:04.028 INFO: [22] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#648: Logging in.
2020-04-03 08:56:04.264 INFO: [22] [hostname=localhost id=shard] MucClient$MucWrapper.join#751: Joined MUC: jvbbrewery@internal.auth.test.abc.com
SCTP JNI load: Linux OS detected
SCTP lib loaded
=====>: org_jitsi_modified_sctp4j_SctpJni.c calling init
=====>: org_jitsi_modified_sctp4j_SctpJni.c about to set SCTP_DEBUG_ALL
2020-04-03 08:56:04.922 INFO: [17] Health.doRun#294: Performed a successful health check in 2790ms. Sticky failure: false
2020-04-03 08:56:14.925 INFO: [17] Videobridge.createConference#326: create_conf, id=da57a38826f1b308 gid=null logging=false
2020-04-03 08:56:14.954 INFO: [17] Health.doRun#294: Performed a successful health check in 29ms. Sticky failure: false
2020-04-03 08:56:24.955 INFO: [17] Videobridge.createConference#326: create_conf, id=dc1fbae8e6cf75db gid=null logging=false
2020-04-03 08:56:24.983 INFO: [17] Health.doRun#294: Performed a successful health check in 28ms. Sticky failure: false

Have you noticed this new line in Quick install doc?

And comment the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES . See the documentation of ice4j for details.