Issue with Jibri visiting URL

I’m trying to stream to livepeer but I’m facing an issue with jibri visiting URL. Let’s say if the public URL is https://abc.com/myroom then in the logs the visiting URL is https://abc.com instead of https://abc.com/myroom hence causing the below errors.

Parsed call url info: CallUrlInfo(baseUrl=https://abc.com, callName=bl, urlParams=[])

Starting a stream with params: ServiceParams(usageTimeoutMinutes=0, appData=null) StreamingParams(callParams=CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://abc.com, callName=bl, urlParams=[]), email='', passcode=null, callStatsUsernameOverride=, displayName=), sessionId=jwryilupvhnkxpag, callLoginParams=XmppCredentials(domain=recorder.abc.com, port=null, username=recorder, password=*****), rtmpUrl=rtmp://rtmp.livepeer.com/live/XXX, viewingUrl=null)

Jibri 2022-03-25 16:21:18.928 INFO: [72] AbstractPageObject.visit#32: Visiting url https://abc.com
jitsi_jibri.1.ih1lpozy4tde@ubuntu-s-4vcpu-8gb-intel-blr1-01    | Jibri 2022-03-25 16:21:19.179 SEVERE: [72] [session_id=jwryilupvhnkxpag] JibriSelenium$joinCall$1.run#327: An error occurred while joining the call

org.openqa.selenium.WebDriverException: unknown error: net::ERR_CONNECTION_REFUSED

Even when the subdomains are enabled and if the URL is https://abc.com/myroom/abc then the visiting URL is https://abc.com/myroom instead of https://abc.com/myroom/abc. I’m building my own docker image with an unstable build(tried stable as well but the result is the same).

CC: @Freddie @emrah Could you please help? Sorry for tagging.

I don’t use Jibri much so can’t offer anything concrete, but looking at the code it seems normal for Jibri to first visit the home page before joining the room.

so from this, I’d expect Jibri to first load https://abc.com to sort out credentials and participant data, then https://abc.com/bl to join actual room.

Your logs would indicate it failed on the first hurdle. Are you sure the site is accessible by your Jibri instance?

Thanks a lot Shawn. Yes, Jibri couldn’t access the ‘https://abc.com’ URL. I was using the wrong IP.

extra_hosts:
            - "abc.com:1.2.3.4"  

1.2.3.4 was wrong.