Issue in docker jibri, Even after adding "recorder@recorder.meet.jitsi" to the admin list

Hi Team,
I have configured Jitsi with a docker-compose setup.
JWT authentication is enabled and we successfully joined the room using the JWT token.
I have also added Jibri’s domain "recorder@recorder.meet.jitsi to the prosody admin list to resolve the unauthenticated/token-nil issue.

Prosody Config Location: /home/ubuntu/.jitsi-meet-cfg/prosody/config/conf.d/jitsi-meet.cfg.lua

The above-given picture is the prosody logs, Here you can see that jibri is authenticated “Authenticated as recorder@recorder.meet.jitsi”.

But after this, another error is “Token nil not allowed to join: lol@muc.meet.jitsi/…”

Room_Name: lol

@emrah @damencho Could you please help me with this

Does Jibri work when the token auth is disabled?

Yes, Initially we tested without JWT

I’m not familiar with Dockerized setup. For the standard deployment, all you need to do is to add “recorder@...” into the admins list.

Another alternative is to disable “enable_domain_verification

I just changed the value to false, But still we have the same issue.

c2s556046affd90 info Authenticated as recorder@recorder.meet.jitsi

muc.meet.jitsi:token_verification error Token nil not allowed to join: hope@muc.meet.jitsi/c5176474

In the above logs, you can see that the room name is added to the muc.meet.jitsi

“hope@muc.meet.jitsi/c5176474” - Any idea about this?

Is this related to jitsi domain strip ?

Adding @saghul to this thread