Is there anyway to reduce the internet banwidth


#1

Hi @damencho,

My jisti meet is working fine and I am enjoying the conference meeting with it. Many thanks t you guys for help and such a nice product.

Is there anyway so that I can reduce the bandwidth during the video conference chat. Because its taking too bandwidth right now when I play other videos with it then other getting too slow due to jitsi, if I stop conferencing with jitsi our other video getting play smoothly.

Please suggest if anything help me on this.


#2

You can click the three dots on the right and then “Manage call quality”, there you can request lower resolution or audio only.


#3

Is there anything which is managed by code so that meeting automatically start with low resolution ?


#4

No, I’m afraid there is no such option.


#5

What should be the standard internet speed bandwidth for video conferencing using kitni.


#6

It depends whether you use simulcast or not, there are some very rough estimations here: Bandwidth cost modeling its about costs but there is also bandwidth. Does that help?


#7

If I used below code then will it work ? will it reduce the use if bandwidth?

Have you tried setting this in config.js:

 resolution: 180,
 constraints: {
     video: {
         aspectRatio: 16 / 9,
         height: {
             ideal: 180,
             max: 180,
             min: 180
         }
     }
 },

Resolution is used in some cases, like chrome < 61, so you need and the
constraints for the newer versions.

It is answered by you.


#8

I have tried with this, I have added like this but not working, meeting still creating in HD

       if (loggedUser && loggedUser != '') {
            var mID = getUrlVars()["m"];
            var userName = 'Jollity';
            var meetingRoomName = mID;
            // Call APi an dget full user details here
            var domain = "jitsi.jollityoys.com";
            var options = {
                roomName: meetingRoomName,
                width: 580,
                height: 480,
                parent: undefined,
                configOverwrite: {},
                interfaceConfigOverwrite: {
                    filmStripOnly: false
                },
                resolution: 180,
                constraints: {
                     video: {
                         aspectRatio: 16 / 9,
                         height: {
                             ideal: 180,
                             max: 180,
                             min: 180
                         }
                     }
                },
            } 

            var api = new JitsiMeetExternalAPI(domain, options);
            api.executeCommand('displayName', userName);

#9

@damencho: Please check my above configuration and please let me know if doing anything wrong.


#10

If you want to override the constraints in config, you need to nest the overrides configOverwrite.

var options = {
  ...
  configOverwrite: {
    constraints: {
      ...
    } 
  } 
}

#11

@Lenny8: I have added but still meeting started with HD not regular quality. See my code below

            var meetingRoomName = mID;
            // Call APi an dget full user details here
            var domain = "jitsi.jollityoys.com";
            var options = {
                roomName: meetingRoomName,
                width: 580,
                height: 480,
                parent: undefined,
                configOverwrite: {
                    resolution: 180,
                    constraints: {
                        video: {
                            aspectRatio: 16 / 9,
                            height: {
                                ideal: 180,
                                max: 180,
                                min: 180
                            }
                        }
                    },
                 },
                interfaceConfigOverwrite: {
                    filmStripOnly: false,
                },
            } 

            var api = new JitsiMeetExternalAPI(domain, options);
            api.executeCommand('displayName', userName);

#12

It seems to be working for me. When starting a call with constraints overridden, the constraints are respected. I think the difference is you’re expecting the slider in “Manage call quality”, which adjusts receive quality, to be configurable through an override but it’s not configurable through an override right now.


#13

Yes actually I was thinking this slider will manage from this code, so could you please guide me how can I check the effect of code like this code is taking less bandwidth of internet, is there any way so I can check ?


#14

Not entirely sure. You can look at the bitrate from the stats that display when hovering over the connection indicator on the thumbnails. You could look at chrome://webrtc-internals and look for recv (ssrc) (video) or send (ssrc) (video) and look at how much is being sent out. Both features I think leverage the same data from the internal webrtc getStats() call.