Is there a way to show only "Your entire screen" tab and not others?

Welcome to the forum!

In your config.js, set the following:

desktopSharingChromeSources: ['screen'],

Could you help me with this too?

Problems occurred during screen share,

  • When the user enables “Share audio” checkbox, the screen share stops.
  • There’s no api call when user clicks “Cancel”, so that we can show the Share your screen popup permission again.
  • While screen sharing is on, if the user redirects to another page in chrome, the screen share automatically stops.

Is there a way

  • to show only “Your entire screen” tab and not others?

  • to hide the “share audio” checkbox

  • And is there any api call, when the user clicks on “Cancel” from Share your screen popup.

Screenshots:

@Freddie And I think this desktopSharingChromeSources has been changed to desktopSharingSources. And its only for electron client.
Link - desktopSharingChromeSources don't change screen sharing options · Issue #1167 · jitsi/lib-jitsi-meet · GitHub