Is there a way to build an URL link that grants moderator rights

If I understand right, it is not in the base config… I have to load this as an extra module, right?

I will read again further on the subject today… Thanks a lot for your help, I really appreciate you taking the time. Hope I can make it up to the community soon by releasing guides that will be helpful for newcomers to Jitsi-meet (and lower the number of requests your team receives!)

Sorry to ask again, but from what I can see, this module is part of the normal jitsi-meet-docker stack (I can see it in the modules)

Now, how do you activate it and how do you create a list of moderated rooms? I can’t find it!
(I realize that since I will be using 114 moderated rooms and many, many unmoderated ones, I should use the subdomain way)

Component "conference.domain.com" "muc"
...
...
modules_enabled = {
	"muc_allowners";
}
allowners_moderated_subdomains = {"mymoderatedtenant"}
allowners_moderated_rooms = {"mymoderatedroomname"}

Do I enter this in the main prosody.cfg file or in the one located in conf.d ?
Also, since I use the docker version I imagine that I will be using “conference.meet.jitsi” as it is the internal virtual domain for the docker version… right?

Yep, and this should be under the muc component. Should be here: https://github.com/jitsi/docker-jitsi-meet/blob/master/prosody/rootfs/defaults/conf.d/jitsi-meet.cfg.lua#L157
Probably you can add it to env.XMPP_MUC_MODULES, and in the cfg just add allowners_moderated_subdomains and allowners_moderated_rooms.

and in the cfg just add allowners_moderated_subdomains and allowners_moderated_rooms

In the config.js file for the web section?

Something like:
allowners_moderated_subdomains=true ???

Nope, in the prosody config. The example I gave you should how your prosody config needs to look like when prosody starts.

Oh god… it worked but it did not have the intended behavior :frowning:
I feel really bad because I really don’t understand how to achieve what I am trying to.

Now rooms are created by people with token, but everyone is Admin in them.
But guests cannot open rooms themselves.

My need are the following:

  1. Guests have to be able to open rooms freely, with or without moderator rights… I couldn’t care less!
  2. Admins with JWT tokens need to be moderators in the rooms they open/join with said tokens.
  3. As a bonus, if I can decide that some rooms are “reserved” and can’t be opened by anyone except someone with a token, that is a plus

There is an option allow_empty_token setting.


This allows people without token to enter meetings.
And then you can use moderated subdomain to have moderators with tokens and the rest are guests

The empty token bit is ok…
image

But when I use the module you referred to previously, everyone becomes a MODERATOR, everywhere… This is not what I need!

Well, this is what it does… You can modify it to serve your needs

Or based on that code, create a custom one

Okay, I will look into it…
But there isn’t there a parameter, anywhere that would allow me to give permission to guests to create rooms but not have moderator rights? because that is how the meet.jit.si behaves from my perspective!

Nope, meet.jit.si is running with exactly this allowners enabled, everyone is a moderator.

Oh! but why won’t the moderator “star” appear then? That is what confused me!

My instance:
image

Meet.jit.si
image

You can do that by setting in interface config: DISABLE_FOCUS_INDICATOR: true,

Oh… that is neat!

I will give your plugin one last try, but for that I need to understand how to make subdomains work in jitsi-meet-docker!

I want to be able to use meet.mydomain.com/subdomain/roomname like you did on the public instance…
This way, I can make a complete subdomain moderated and the main one a big free-for all!

EDIT: And if I get it right, that subdomain won’t permit guests to create rooms if I specify it in the cfg file right?

Not really, tenants/subdomains should already be working for you . And they use the main virtual domain for the token config and whatever you set there. So it will be for the whole deployment.
Tenants/subdomains are enabled by just enable muc_domain_mapper module and one setting:


A and some nginx configs … but I’m thinkingn those should already be in docker … ah and a config.js change … but there is the PR with all needed changes:

If I try to use a subdomain (mydomain.com/subdomain/room) I get a 404 error… I am searching for the solution at the moment, but keep getting dead ends :expressionless: