Is there a way to access jitsi-meet from local IP and public IP

I installed Jitisi-meet on a server which has internet IP address. Participants from the same local network of the server cannot access the internet, so I add the local IP of the server in the host of the participants to map the domain to the server’ local IP.
Then the participants were able to join the meeting, but, were dropped out after a seconds.
The meeting display below information:
“You have been disconnected.”
“You may want to check your network connection. Reconnecting in 10 sec…”

Can you share the browser console logs for a user that gets the failure?

Thanks for your quick response.
My partners reported this issue to me, and I fogot to ask them to give me the console log.
I will ask them to help when they are free.

To reproduce this issue, I tested on my lab enviroment as below:
1)One ubuntu cloud server, which jitsi-meet was installed on it (meeting server)
2)One ubuntu cloud server with desktop and VNC on it (desktop machine)
3)The two server were in a local network area, and both were able to access the internet
4) I added domain / ip map in the host of the desktop machine, the domain is the public domain of the meeting server and the ip is its internal IP not its public IP
The steps were:
1)I hosted a meeting from a computer of windows 10
2) I joined the meeting from the desktop machine, it worked well
3) I captured the network traffic from the desktop machine, found that the traffic from the meeting server was from the public IP, not the internal IP.

Do you have this option enabled in your server? jitsi-videobridge/reference.conf at 3c9d3c5211297d647d452ae72df18697d9966d5c · jitsi/jitsi-videobridge · GitHub

Which option? I installed Jitsi-meet on docker, below is the content reference of jvb.conf:
videobridge {
ice {
udp {
port = 10000
}
tcp {
enabled = false
port = 4443

    }
}
apis {
    xmpp-client {
        configs {
            shard {
                HOSTNAME = "meeting.test.com"
                DOMAIN = "auth.meeting.test.com"
                USERNAME = "jvb"
                PASSWORD = "853deefb16d09cb1d843a6eaa56cc947"
                MUC_JIDS = "jvbbrewery@internal-muc.meeting.test.com"
                MUC_NICKNAME = "gw28181"
                DISABLE_CERTIFICATE_VERIFICATION = true
            }
        }
    }
}
stats {
    enabled = true
}
websockets {
    enabled = true
    domain = "meeting.test.com"
    tls = true
    server-id = "172.17.73.109"
}
http-servers {
    private { 
      host = 0.0.0.0
    }
    public {
        host = 0.0.0.0
        port = 9090
    }
}
cc { 
  trust-bwe = false 
  } 

}

ice4j {
harvest {
mapping {
stun {

            addresses = [ "meet-jit-si-turnrelay.jitsi.net:443" ]

        }
    }
}

}

If you are using Docker try this: set DOCKER_HOST_ADDRESS to the LAN IP of your machine.

Thanks a lot, I will try it later

I tested and it works fine now