Is there a documentation for the lobby feature just arrived

If lobby don’t appear that’s because client don’t see it advertised by the server. Maybe prosody version ? or something else in the prosody config if you did not paste the full thing.

Attached is the full config file. domain.cfg.lua.txt (3.4 KB)

Prosody Version is 0.11.4

root@ubuntu-s-1vcpu-2gb-nyc1-01:/etc/prosody/conf.avail# prosodyctl about
Prosody 0.11.4

# Prosody directories
Data directory:     /var/lib/prosody
Config directory:   /etc/prosody
Source directory:   /usr/lib/prosody
Plugin directories:
  /usr/share/jitsi-meet/prosody-plugins/
  /usr/lib/prosody/modules/


# Lua environment
Lua version:                    Lua 5.2

Thank you for your support.

Don’t see much significant differences; it’s difficult to compare files with different sections orders.

  • no ssl section: very probably irrelevant. I don’t even know what is the use of this in my config file
  • you have one time internal_hashed and one time internal_plain. My config is less recent and I have 2 times the same auth: internal_plain. No idea if this is a problem.
  • I have muc_domain_mapper module in internal auth section. Again no idea if this could make a difference.
  • I have the duration stuff in the anonymous host. I’m pretty sure that it did not work when I had it in the authenticated host (I have commented it). But I don’t see a possible link with lobby.
    That’s all, I have found nothing like a smoking gun. Sorry.

Hi there,

I’ve prosody 11.2 and i edited this file ( /etc/prosody/conf.avail/jitsi.example.com.cfg.lua) and made the changes like you said…

butstill nothing works… any idea what’s wrong… ? or something i’ve missed

Thanks in Advance

it’s still necessary to apply the patch with version

ii  jitsi-meet                     2.0.4803-1                        all          WebRTC JavaScript video conferences

can you post the /var/log/prosody/prosody.log file after the line containing
Lobby component loaded lobby…

Thanks for the quick revert… It’s a huge file… so attaching here…

prosody.log (1.2 MB)

in this current set up… my audio & video is blocked due to the setup i did for lobby rooms on (https://meet.impactvideo.co.in)

nothing of interest here. Can you post your (site).cfg.lua ?

You dont edit the /etc/prosody/conf.avail/jitsi.example.com.cfg.lua file.

You edit this one : /usr/share/jitsi-meet/prosody-plugins/mod_muc_lobby_rooms.lua

my dpkg -l| grep jitsi is

root@ubuntu-s-1vcpu-2gb-nyc1-01:/usr/share/jitsi-meet/libs# dpkg -l| grep jitsi
ii  jitsi-meet                     2.0.4808-1                            all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody             1.0.4249-1                            all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver          1.0.4249-1                            all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                 1.0.4249-1                            all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config          1.0.4249-1                            all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2             2.1-265-g7da86401-1                   all          WebRTC compatible Selective Forwarding Unit (SFU)

But I still dont see the Enable Lobby Screen. Any changes need to be done on the interface config or anywhere else?

after reading again your file I realize that probably the reason I can’t see the problem is that you edited it to hide your domain, and the problem is here, that is, the domain names.

VirtualHost “guest.mydomain”
(…)
lobby_muc = “lobby.mydomain”
(…)
Component “lobby.meeting.mydomain” “muc”

should be
lobby_muc = “lobby.meeting.mydomain”
I think.

but i’ve now updated this file:- /usr/share/jitsi-meet/prosody-plugins/mod_muc_lobby_rooms.lua

– This module added under the main virtual host domain
– It needs a lobby muc component

VirtualHost “guest.meet.impactvideo.co.in”
modules_enabled = {
“muc_lobby_rooms”
}
lobby_muc = “lobby.meet.impactvideo.co.in”
main_muc = “conference.meet.impactvideo.co.in”

Component “lobby.meet.impactvideo.co.in” “muc”
storage = “memory”
muc_room_cache_size = 1000
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

yes yes yes yes. thank you. :slight_smile:

Hi jitsi community.

I’m just new to all things jitsi and so I apologize for any remedial questions. Trying to test out this lobby patch but I can’t seem to figure out where / how to get the specific versions of the various jitsi-meet* packages as listed here:

Generally speaking … I know how to git clone a specific branch by tag name.
But it’s not clear to me where the code / repos are for the other components listed, like jitsi-meet-prosody, or turnserver etc.

I went to https://github.com/jitsi and tried to search but couldn’t find.
Can you point me in the right direction?
Please and thanks!

According to the experts, installing from source takes one hour if you have years of experience. As you have less than one hour of experience installing from source will take you years.

you need to go to the doc, and to the quick install to setup a server and get a hang on the system.

As of the lobby, it’s still in the unstable branch and as such not really for beginners.

So I have a jitsi server already running with the following packages/versions:

root@mylab:~# dpkg -l | grep jitsi
ii  jitsi-meet                        2.0.4627-1                    all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody                1.0.4127-1                    all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-web                    1.0.4127-1                    all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config             1.0.4127-1                    all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                2.1-202-g5f9377b9-1           all          WebRTC compatible Selective Forwarding Unit (SFU)

So I’ve kinda already done the install and basic setup and it works.
I need a way to test the lobby feature. Is this not the right place to ask?

great, now this not only the place to ask, but the place to find the answer since it has already been posted in this thread. Take note particularly of the point 1, since you have to follow it and so rip out your install.

Hi,
is this feature enabled in docker already? if not can anyone please let me know when will lobby room feature be added to docker image?

Thanks in advance

3 Likes

not yet, you can visit this page to see what happens for docker, it should not be long since new debian stable with lobby is out now - last time there was about 10 days between debian stable and docker release.
Note that there is a subscribe option at the top of the Github page, you have fo create an account.

1 Like

I just learned through trial and error that if you have a “secure_domain” configuration the config lines for lobby have to be removed from the “main” VirtualHost and moved accordingly to the “guest” VirtualHost to get a working lobby.
If you add the lines to both VirtualHosts you get a lobby, but users won’t be able to join. The moderator never gets a notification for waiting users…
I use the stable debian packages:
jitsi-meet 2.0.4857-1
jitsi-meet-prosody 1.0.4289-1
jitsi-meet-turnserver 1.0.4289-1
jitsi-meet-web 1.0.4289-1
jitsi-meet-web-config 1.0.4289-1
jitsi-videobridge2 2.1-273-g072dd44b-1

Lobby is now available on default installation of jitsi meet, make sure you install prosody version>=0.11.4 to make it work correctly it won’t work on prosody 0.10. To install that you need to add prosody repository and key, (the terminal command can be found from prosody site) before issues apt install jitsi-meet command. Thanks jitsi meet team for the great update.