Is someone working on Safari compatibility?

@jallamsetty
here are the logs of an IPhone 10:

Although the logs state that possibly the permissions were not granted, this is not the case. When asked, I granted them and I also tried it with automatically granting it.

Okay, video is working now. I just needed to double tab video and mic to activate it on the iphone, but mic is still not working. In the settings of jitsi, the audio is recognized well, but they can’t speak in the meeting.

I already tried to overwrite the enableNoisyMicDetection: true option in the config.js (https://github.com/jitsi/lib-jitsi-meet/issues/1126) by using:

const options = {
    configOverwrite: {
        disableDeepLinking: true,
        p2p: {
            enabled: false,
        },
        enableNoisyMicDetection: false,
    }
}

but that does not work. Does anybody had that same issue and know how to fix it?

1 Like

I’ve never gotten audio (mic) working in my tests with an iPad and an iPhone XR running latest iOS, exactly the problem you described.

@densi_1101, will you be able to provide the full log, the error message that you are referring to doesn’t seem to be relevant to the getUserMedia call for the audio or video devices.
Also, we have disabled noisy microphone detection for Safari browser by default, so you shouldn’t be running into that issue if you are using meet.jit.si or deployed the updated packages from the stable repo.

I have updated to latest unstable build and testing ios safari with disableDeepLinking: true in config.js ;

I still observe Browser Warning on Safari browser of iphone
&
Even my setup doesn’t have any problems on web, on mobile phone’s chrome browser it returns with unfortunatelly something went wrong.

In config.js i already have disableH264: true,

Any advice for these two issues?

The browser warning has been removed, make sure safari is added to the list of optimal browsers here - https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L179

Are you trying to run chrome browser on iPhone or Android ? It is not clear from your post. We do not support chrome browser on iPhone.

It was on iphone, so it is not supported…
And i was using alias interface_config in another folder not to be overwritten during upgrades, thats’s why i missed that optimal browsers setting, i will add it manually thanks…

One last question; now we can make it work on safari without a need of app which is good; but the general bahaviour is not so great. It still needs a better look and feel and user experience with some css work probably; are there any plans about that? To make a better layout and view for mobile native browsers?

And also as @densi_1101 commented in Is someone working on Safari compatibility? , is there any updates about “need to double tab video and mic to activate it on the iphone” @jallamsetty

And any updates about 3 options; download app, continue to app and continue with browser ??

1 Like

Mic is still not working under IOS 13 Safari Browser. I’m not sure if these errors are the real cause for this problem but anyways, here are the errors I still get:

Selection_025 Selection_026

1 Like

Maybe my problem is related: https://github.com/jitsi/jitsi-meet/issues/6865

IFrame API: Desktop Safari (13.1 od Ipad OS 13.5): TypeError: null is not an object (evaluating ‘e.getAudioTracks’) on Camera Activation

On current Desktop Safari (13.1 od Ipad OS 13.5) I get an JS exception when I want to activate the camera.

TypeError: null is not an object (evaluating 'e.getAudioTracks')

This error happens only if the room is all-ready created. If I am the first in the room, then the camera will be activated.
When I join the room without the IFRAME API directly with the jitsi meet url, then it works.
I have tested it with the latest nightly build (jitsi-meet_4649), the current stable version and the the public server https://meet.jit.si

Mobile Safari (IOS 13.5) works with IFrame API Setting

configOverwrite: {
 disableDeepLinking: true,
}

Please open a new topic for new subjects.

@omesta, we have plans of improving the UX on mobile safari but its not happening soon. Wee have added the “Launch in Web” button to the mobile deeplinking page so you should see all the 3 options when you get the packages from unstable repo.

@densi_1101 The audio issue seems to be webkit bug on iOS 13, the workaround for now is to double tap on the video and mic button on the browser tab.

@informatikTirol, are you joining the call with startWithVideoMuted config.js option with the iframe API ?

@jallamsetty
no, here are my changes in config.js

channelLastN: 1,
disableAudioLevels: true,
enableClosePage: false,
disableInviteFunctions: true,

doNotStoreRoom: true,

If the client is localhost, it does work…

The audio issue with safari mobile on iOS 13 and newer versions should be fixed now. Can you all please try against https://alpha.jitsi.net/ or get the latest from unstable repo ?

Will it not work on IOS versions below 13. I am testing on IOS 12.4.6 and the audio doesn’t work. Is there a possibility to support the lower versions any time soon? Thanks!

Yeah, the beta works in IOS 12.4.7 But I tried http://meet.jit.si and https://alpha.jitsi.net before and it didn’t work on both of them. Any idea why?
Also, the audio on beta started working after a bit of delay and not after joining the call.

I have the following problem :

Safari (Mac 13.1.1, IPAD OS 13.5.1, IOS 13.5.1): Screen freezes when other user starts screen sharing

I noticed in the meet.jit.si/config.js that the websockets are enabled
Why is that