Is old jibri still working with new jitsi-meet?

Hi,

FYI my jibri working on on jitsi-meet/stable,now 2.0.5076-1.

Because we need image background, i make new jitsi-meet on bullseye.
Just wonder if new jitsi-meet is working on old jibri?
Here is my version:

jitsi-meet/stable,now 2.0.6173-1
jibri/stable,now 8.0-14-g0ccc3f6-1

I already tried to integrate them both, but i still failed.
Jibri already connected to jiitsi server, but when recording:

  1. sometime recording crash when some people entered the room.
  2. sometime confrence is crash when stoping recording.

Share your jicofo.conf

Updated issue:

  1. sometime recording crash when some people entered the room.
  2. sometime conference is crash when stoping recording.
  3. sometime no audio and video

Weird when i said sometime… But that what happen…
Here is my jicofo.conf, i replace my server to xxx

jicofo {
  xmpp: {
    client: {
      client-proxy: focus.xxx
    }
    trusted-domains: recorder.xxx
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.xxx"
  }
}

Forgot to mentioned, i use 2 jibri server… All identical except jibri and recorder user.

1 Like

Change this line:

To:

trusted-domains: [recorder.xxx]

Then restart services and try recording again.

Thanks you…
For this test im only using 1 jibri sever. I’ve added a bracket to my conf file, and it seem no crash happen when i recording a test conference. Let me test couple scenario and i will post the result later.

Hi again,
After several days idle, some user tried to record a meeting but failed. Here is the log for it.

2021-10-04 10:24:56.985 INFO: [31159] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Quitting chrome driver
2021-10-04 10:24:57.119 INFO: [31159] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Chrome driver quit
2021-10-04 10:24:57.119 INFO: [31159] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Finalizing the recording
2021-10-04 10:24:57.491 SEVERE: [31172] org.jitsi.jibri.selenium.JibriSelenium.run() An error occurred while joining the call: org.openqa.selenium.NoSuchSessionException: Session ID is null. Using WebDriver after calling quit()?
Build info: version: 'unknown', revision: 'unknown', time: 'unknown'
System info: host: 'jibri1', ip: '127.0.1.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.19.0-9-amd64', java.version: '1.8.0_252'
Driver info: driver.version: RemoteWebDriver with stack: 
org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:125)
org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:543)
org.openqa.selenium.remote.RemoteWebDriver.executeScript(RemoteWebDriver.java:480)
org.jitsi.jibri.selenium.pageobjects.CallPage$visit$1.apply(CallPage.kt:48)
org.jitsi.jibri.selenium.pageobjects.CallPage$visit$1.apply(CallPage.kt:33)
org.openqa.selenium.support.ui.FluentWait.until(FluentWait.java:248)
org.jitsi.jibri.selenium.pageobjects.CallPage.visit(CallPage.kt:47)
org.jitsi.jibri.selenium.JibriSelenium$joinCall$1.run(JibriSelenium.kt:256)
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
java.util.concurrent.FutureTask.run(FutureTask.java:266)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

2021-10-04 10:24:57.491 INFO: [31172] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2021-10-04 10:24:57.492 INFO: [31172] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call
2021-10-04 10:24:57.492 INFO: [31172] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Current service had an error, sending error iq <iq to='jibribrewery@internal.auth.vc.inti.co.id/focus' id='1dmvV-62328' type='set'><jibri xmlns='http://jitsi.org/protocol/jibri' status='off' failure_reason='error'/></iq>

Any suggestion??
or it would be best if im making new jibri from scratch??

This is not the complete log. Clear the log, restart Jibri and try again, then share the complete log after that.

Meanwhile, what version of Chrome do you have installed on your server? What about Chromedriver?