Is my token structure correct?

hi jitsi team
Is my token structure correct?
mytoken:
eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJjb250ZXh0Ijp7InVzZXIiOnsiYXZhdGFyIjoiaHR0cHM6Ly9ncmF2YXRhci5jb20vYXZhdGFyLzg2Y2Y3ZTEzOGVkZDdkZjUyYzNmZWFhMGNkZGFmMGZhP3M9NDAwJmQ9cm9ib2hhc2gmcj14IiwibmFtZSI6IkpvaG4gRG9lIiwiZW1haWwiOiJqZG9lQGV4YW1wbGUuY29tIn19LCJhdWQiOiJBT1JDQUJBREFOIiwiaXNzIjoiaml0c2kuYWJhZGFuLm9yZyIsInN1YiI6IkFPUkNBQkFEQU4iLCJyb29tIjoidGVzdG5ldyJ9.Uj0a5pt2_KqRl44iBNQtdNzUnBGZ1QAx2h88IAtU3oY

header :
{
“alg”: “HS256”,
“typ”: “JWT”
}

payload:
{
“context”: {
“user”: {
“avatar”: “https://gravatar.com/avatar/86cf7e138edd7df52c3feaa0cddaf0fa?s=400&d=robohash&r=x”,
“name”: “John Doe”,
“email”: “jdoe@example.com
}
},
“aud”: “AORCABADAN”,
“iss”: “jitsi.abadan.org”,
“sub”: “AORCABADAN”,
“room”: “testnew”
}

signature:
SklUU0k+QUJBREFOPk9SRw==

I have completed the token installation process from https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md but video is not displayed

sample

I did all the installation steps but the video is not displayed.
I have not been able to install and run the token for about a month. please help
I need token configurations on Ubuntu 20.04
As well as the structure of the token itself
pleaseeeeeeeeeeeeeeeeee help

First, install a working Jitsi. Test it with 2 and 3 participants. If it’s OK then install the token auth using these steps

I installed jitsi and it works perfectly
But it does not work in token mode
I do not know if the form is a token structure or a prosody configuration

hi emrah
Thank you for your response
I created the token from the sample you sent
Displays the user profile
But the video does not show

my token is:
eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJjb250ZXh0Ijp7InVzZXIiOnsiYXZhdGFyIjoiaHR0cHM6Ly93d3cuZ3JhdmF0YXIuY29tL2F2YXRhci8yMDVlNDYwYjQ3OWUyZTViNDhhZWMwNzcxMGMwOGQ1MC5qcGciLCJuYW1lIjoiRXlkYW4iLCJlbWFpbCI6Im5ld3VzZXJAZXhhbXBsZS5jb20ifX0sImF1ZCI6ImFvcmNhYmFkYW5yZWZpbmVyeSIsImlzcyI6ImFvcmNhYmFkYW5yZWZpbmVyeSIsInN1YiI6ImppdHNpLmFiYWRhbnJlZmluZXJ5Lm9yZyIsInJvb20iOiJ0ZXN0bmV3In0.V5hM6KIJKaKmDXgfpmsJCaWDvNzH5iteo3SMlaEmzmE

my prosody config is :

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “jitsi.abadanrefinery.org”;

turncredentials_secret = “IGnpBifiTqXEvcZx”;

turncredentials = {
{ type = “stun”, host = “jitsi.abadanrefinery.org”, port = “3478” },
{ type = “turn”, host = “jitsi.abadanrefinery.org”, port = “3478”, transport = “udp” },
{ type = “turns”, host = “jitsi.abadanrefinery.org”, port = “5349”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
– https_ports = { }; – Remove this line to prevent listening on port 5284

https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline>
ssl = {
protocol = “tlsv1_2+”;
ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE>
}

VirtualHost “jitsi.abadanrefinery.org
– enabled = false – Remove this line to enable this host
– authentication = “anonymous”
authentication = “token”
c2s_require_encryption = false

  allow_empty_token = true
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
   app_id="aorcabadanrefinery"
   app_secret="UjXn2r4u7x!A%D*G-KaPdSgVkYp3s6v8"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.

ssl = {
key = “/etc/prosody/certs/jitsi.abadanrefinery.org.key”;
certificate = “/etc/prosody/certs/jitsi.abadanrefinery.org.crt”;
}
speakerstats_component = “speakerstats.jitsi.abadanrefinery.org
conference_duration_component = “conferenceduration.jitsi.abadanrefinery.org
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
“muc_lobby_rooms”;
“presence_identity”;
}
c2s_require_encryption = false
lobby_muc = “lobby.jitsi.abadanrefinery.org
main_muc = “conference.jitsi.abadanrefinery.org
– muc_lobby_whitelist = { “recorder.jitsi.abadanrefinery.org” } – Here we can whitelist jibri to>

Component “conference.jitsi.abadanrefinery.org” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
“token_verification”;
}
admins = { “focus@auth.jitsi.abadanrefinery.org” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.jitsi.abadanrefinery.org” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.jitsi.abadanrefinery.org”, “jvb@auth.jitsi.abadanrefinery.org” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.jitsi.abadanrefinery.org
ssl = {
key = “/etc/prosody/certs/auth.jitsi.abadanrefinery.org.key”;
certificate = “/etc/prosody/certs/auth.jitsi.abadanrefinery.org.crt”;
}
authentication = “internal_plain”

Component “focus.jitsi.abadanrefinery.org
component_secret = “7jU3wfGH”

Component “speakerstats.jitsi.abadanrefinery.org” “speakerstats_component”
muc_component = “conference.jitsi.abadanrefinery.org

Component “conferenceduration.jitsi.abadanrefinery.org” “conference_duration_component”
muc_component = “conference.jitsi.abadanrefinery.org

Component “lobby.jitsi.abadanrefinery.org” “muc”
storage = “memory”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “guest.jitsi.abadanrefinery.org
authentication = “token”
app_id=“aorcabadanrefinery”
app_secret=“UjXn2r4u7x!A%D*G-KaPdSgVkYp3s6v8”
c2s_require_encryption = true
allow_empty_token = true

please help me
I have not been able to solve this problem for more than a month

No need to edit the prosody config manually. If you don’t see the changed values after an usual install, this means that there is something wrong.

I recently created two docs with how to install jitsi meet + jwt on ubuntu 18 and 20 (with video)

https://github.com/christiancuri/Docs

its worked.
Thank you very much

What changes should I make to the token to determine if the user is an admin or a guest?

Search for token_moderation or token_affiliation modules