Is it possible to hide the room name?

We’re using the Jitsi Meet External API. Over the last couple of weeks, our rooms are showing the Room Name and a button with the number of participants. These two UI elements are floating over the video, with a slight, gradient overlay. How can we hide those two elements and the overlay?


1 Like

Currently there is no such setting. Any contribution is welcome.

1 Like

May I ask is there any update for this case? still can not ?


Nope, there is no update. This is low priority and is not currently on the roadmap. To see such a setting, you can create a PR and we can look at it.
Any contribution is welcome. Thank you.

This is a bit of a hack, but you can run:

   const api = new JitsiMeetExternalAPI(domain, options);
   api.executeCommand('subject', ' ');

and it will set the subject of the meeting to an empty space, making it not appear at the top of the video. Note that it does need at least one space, not just '', as that will evaluate to falsy and it will revert back to the meeting name.


@Jacob_Smith would you be so kind and elaborate why this example works?

Thank you!

1 Like

Thanks a lot… This is want we wanted. Creating a random room name so that no users join the conference by mistake, and a same subject in the video …

Hi Jacob,

how I am can process step to step?

Thank you for your help.
But, like Shimon_Pertz and Eliuas_Xx, I have no clue, where to put it. Does not look like a config file. So somewhere in the source. But where? Does it need to compile?

You can also try passing in the options to the external API:
configOverwrite: { subject: ‘123’ },
I think empty subject will not work.

@damencho Is it possible to pass de ‘123’ as a parameter into the url so to use a room fantasy number?


1 Like

Great @damencho !
It worked fine.

Then when I try with setting also the user name parameter it only takes the first parameter:
This case fails“123”#userInfo.displayName=“Daniel”
It seems that I need a separator before the second #
What would it be?
I’ve tried &,; but nothing works.

I follow a bit trying with & to concatenate two params but it won’t work in Chrome, at least.

On the other hand this works fine in Safari:“nwoodhouse”
But this doesn’t:“Fantasy Room Name”


You separate parameters with &:

Thank you @corby !!! It worked fine in chrome with several parameters.

In chrome works perfect!