Is it possible to disable the jitsi logo watermark on video on self hosted free plan?

Is it possible to disable the jitsi logo watermark on video on self hosted free plan? If yes, how do I do that?

check out /usr/share/jitsi-meet/interface_config.js

I have added HIDE_DEEP_LINKING_LOGO: true in there but it’s not working

Anything I modify in /usr/share/jitsi-meet/interface_config.js doesn’t seem to take effect. Is there some way to restart Jitsi meet

try to set SHOW_JITSI_WATERMARK to false and reset cache (usually Ctrl F5)

Which cache exactly I’m I supposed to reset?

browser’s cache.

I did that and it’s still not working. Do you know if jitsi has it’s own cache that needs to be cleared so that the new configs in interface_config.js can be picked up?

Try checking in incognito (private tab on your browser).

no there is no such thing.
If you do (from the workstation where you still see the watermark on the video)

curl -s -k https://your.url.tld | grep SHOW_JITSI_WATERMARK

do you see your change (that is, a false value)

SHOW_JITSI_WATERMARK: false,

if no there is a problem in what you did, if yes the problem is most probably in your browser. Try to empty the browser cache, or another browser, or whatever.

Thanks, @gpatel-fr. I have verified the update. However, the changes are only appearing on https://myUrl and not https://myUrl/external_api.js. How do I have these changes reflect on https://myUrl/external_api.js? @damencho @Freddie

Some netiquette tip: Shouting out for users that are not involved is not really appreciated and usually has the opposite effect.

My apologies. Thanks for this

I don’t understand what you are trying to do here. External api is just a way to embed your site in another page. If you have changed your site and it displays your logo, it should display in the iFrame api windows. What iFrame Api can NOT do is to change the logo on any Jitsi server you use though the iFrame api. It’s by design.

Thanks @gpatel-fr. What I’m doing is, I have modified the configurations in interface_config.js on my server. One of the configuration disables the jitsi logo. When I start a meeting using https://my-domain/roomId, I see all the configuations working fine and the logo is not there. But when I embed this in my code; <script src=“https://my-domain/external_api.js” …, meetings start without those configurations and the logo is there. What I’m I missing?

Well, I’m stumped here. Just checked again with latest unstable Jitsi and it works fine. I can’t divine what you could do since interface_config is here to parameter stuff that you can NOT override with config.js hence with iFrame API. I don’t see any way forward if you don’t post minimal working code that demonstrates the effect. Or maybe you use an old and bugged Jitsi-meet version ?

I’m using Jisti-meet 2.0.6293-1

that’s not latest stable but not old. It should work; That means that I don’t see a way to help you with little information. Basically it works for me and I don’t know exactly what you are doing.