Is it possible to connect self-hosted Jibri to the public meet.jit.si?

Let’s say we wanted to live stream several meetings held on the public meet.jit.si site. I’ve seen that there is a restriction on the public site that jibri will only record for a maximum of one hour. Our sessions will generally be just slightly longer - maybe 1.5 hours max.

Is it possible to have a self-hosted jibri instance connect to and stream these meetings. For our use-case it would be fine if the jibri appears as a silent participant.

Yep, that is possible as jibri is a normal web client, but you need to start those participants manually through the rest api.

Is this API documented somewhere? Is the API call directed at jitsi-meet or jibri?

You need to call it on the jibri machine manually, there is no way to invite jibri from meet.jit.si as jicofo will not be aware of your jibri.

1 Like

Hello @damencho,

I did some tests but cannot start a recording through API. What is wrong with the following curl request?

curl -X POST -H "Content-Type: application/json" \
  -d '{"sessionId": "mysession", "callParams": {"callUrlInfo": {"baseUrl": "https://meet.jit.si", "callName": "mytest"}}, "callLoginParams": {"domain": "meet.jit.si", "username": "my-anonymous-jibri", "password": ""}, "sinkType": "file" }' \
  http://127.0.0.1:8002/jibri/api/v1.0/startService

note: when I change domain to “auth.meet.mydomain.com” and set the jibri credential, it works but not work anonymously

Same. What I see in the Jibri log when I try is:

Cannot read property `isJoined` of undefined

In my case, I am running the Jibri docker container. And the API for health check returns healthy.

The URL Jibri is trying to connect to is:

https://meet.jit.si/RelativeSpeciesPromiseUndoubtedly#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME="Jibri"&config.analytics.disabled=true&config.p2p.enabled=false&config.prejoinPageEnabled=false&config.requireDisplayName=false

Clients could communicate well in room created at meet.jit.si . The same clients still could connect to my self -hosted instance but can neither hear nor see one another. What’s wrong? Most probably, the server is behind NAT, but you haven’t added the NAT-specific configuration. See this resolved question. You need to follow the steps detailed here.

Did mean to write this post here? It doesn’t seem related to the question I’m asking. Am I missing something?