Is api.amplitude.com required?

I’m using IFrame to put jitsi on our webpage.

I’m having issues with detecting camera and mic. Looking at the console in Firefox, api.amplitude.com it is being blocked due to CORS. And it is also blocked by my PiHole.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.amplitude.com/. (Reason: CORS request did not succeed).

Was this necessary in order for jitsi to work?