iOS Compatibility (older iOS)

Good night everyone. So far I’m working on learning more about Jitsi and setting it up. All seems fine with the exception of older iOS devices.

The setup is done on two different VPSes - finding that the one in the US works better than the one in Gemany due to distance. Most persons can connect so far with no issues, so let me lay out the current problem and hopefully someone can help or share insight.

On iOS desktop/laptop devices (MacBook / iMAC) the users can connect using Chrome or FireFox. Safari just doesn’t work.

On older iOS devices - I have one running 8.x and another on 10.x - the website doesn’t load at all. I managed to load 8x8.vc on the 10.x through the app, but the older device running 8.x won’t load it at all.

The purpose of this is to try and have all users on all devices able to connect. This is to also have older persons who are not very tech-savvy able to connect. If it were possible to force “desktop mode” on the mobile devices, then force everything through the browser that would probably work, but on both older iOS devices I can’t even load the main page. All I get is “You have been disconnected” from within the app and from the browser I get “This site can’t be reached” and “jitsi.yoursite.com unexpectedly closed the connection”.

Are these just limitations with iOS? Will there be no support for the older devices? Just asking for information purposes. If it means some people just won’t be able to use the service - then I guess that’s it.

Thanks in advance. Keep up the good work!

There was a recently fixed bug in the nginx configs that impacts older iOS devices.

Try editing /etc/nginx/modules-enabled/60-jitsi-meet.conf and changing the following:

map $ssl_preread_alpn_protocols $upstream {
        "h2"            web;
        "http/1.1"      web;
        "h2,http/1.1"   web;
        default         turn;
    }

to

map $ssl_preread_alpn_protocols $upstream {
        ~\bh2\b         web;
        ~\bhttp/1\.     web;
        default         turn;
    }

See if that fixes your older iOS devices. If not, please report back, as the intent of this fix was to resolve it!

Good evening. Many thanks for that. So it works with iOS 10.x within the app - the website still doesn’t load in any browser.

On iOS 8.x it doesn’t work either in the app or the browser. But at least it’s a start.

Specifically - on both iOS devices (8.x / 10.x) it no longer gives errors about reaching the site. The tab shows the title but the page loads blank.

If there’s anything else you’d like me to try please let me know. Thanks in advance!

A blank page on an iPhone is actually consistent with the modern iOS behavior - so that’s an improvement.

I’m not sure how much interest there is in supporting ancient iOS versions, but if you’re willing to troubleshoot the issues, probably involving server logs and possibly some packet capture, patches are appreciated!

Is the iOS 8 issue a blocking issue, or a “nice to have”? And how much time do you have to throw at the problem?

Well. Here’s the thing. Especially due to the COVID-19 stuff, I’m trying to assist family/friends that need to meet up and discuss stuff. They’ve tried Zoom and a few other things - may go with Google Hangouts from what I last heard - but being the IT person I did my research and found Jitsi. I’ve seen it working on 8x8.vc so I figure I can get all of the features setup eventually. Removing the watermark isn’t even a concern - that can come later - and I don’t mind people being more aware of the product.

This is a temporary solution until people can socialize once more - and while I have some concerns, let me get into the meat of it - I have a bad habit of being long winded…

  • Easy for everyone to join.
  • Minimal setup required.
  • Very few prompts.

That’s basically what’s needed. I talked to some and they have issues with installing new software much less copying/pasting a URL. The few that have been able to get on with the other platforms took DAYS to get it done.

The issue is that some persons are either older or completely technically inept. So far on Android and desktop (Windows/Mac) it works fine in FireFox or Chrome. The problem is with persons having older devices and being in different countries as well, I can’t validate what each person is using. One older person has a tablet (iPad) which is linked to his son’s account. He can’t install anything on that. And I can’t instruct him on how to find and tell me the iOS version - so I assume it’s an older device.

If it were possible to force “desktop view” or “open desktop site” on the mobile devices I’d do that. This way the users wouldn’t need to download anything and just get on. This doesn’t work with iOS so far unfortunately - all iOS users on various versions (up to 13.x I believe) must download the app in order to join. I don’t know where iOS versions are currently, but 13.x was the last version tested which could access the conference.

Recording is a nice feature and I’ll work on that later. For now using OBS to record the screen will suffice.

The only other feature that would be really nice - is the ability to delegate moderator roles within the conference without having to add using the CLI. As the person with access to the server I’ve already setup 3 moderators. With the exception of the main person doing the presentation, if any of the others are busy or absent then it shouldn’t be a problem. Unlike Zoom there’s no need to validate each person entering.

If an unruly person enters then a feature to blacklist the person for a timeframe would be nice.

Anyhow. Any help is appreciated greatly. And the information will be good for others searching to get a solution if they have similar issues. Thanks again.

I’m not aware of a way to use it in a browser on mobile.

As for “bombing,” just have a screwball server name and long meeting names. That should cover it pretty well - Zoom’s issue is 9-10 digit meeting IDs.

But not having any older iOS devices, I don’t have a good way to test them - sorry. :confused:

That’s fine. If you want to go through it I’m willing to make whatever changes.

As for using it in a mobile browser - on Android all you do is hit the menu (three dots on the right) then go to “request desktop site” or “open desktop view” depending on the Android version.

I tried it on iOS but it failed. Have to use the app.