Invite Button missing from Toolbar

Fixed mine by adjusting the below items. In my case, it seems related to prosody having updated at the same time as jigasi. I assumed it was a jigasi issue, but I think this is related to certs becoming invalid after prosody updates.

  • /etc/jitsi/videobridge/sip-communicator.properties
    replace =localhost your domain to the line below
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=YOUR.DOMAIN.HERE
  • /etc/jitsi/jicofo/sip-communicator.properties (add the line below)
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true
  • sudo systemctl restart jitsi-videobridge2
  • sudo systemctl restart jicofo
1 Like

In my case seams that is not necessary modify /etc/jitsi/videobridge/sip-communicator.properties and /etc/jitsi/jicofo/sip-communicator.properties.

Simply I restarted the jicofo service, after a reboot of machine, and I can use jigasi for outgoing call without problem.

I think that there are a problem with the order which the services start on my Debian machine.

This is the version of my distribution and packages:

Debian Buster 10.4

dpkg -l | grep ji

ii jicofo 1.0-567-1 all JItsi Meet COnference FOcus
ii jigasi 1.1-107-g6928850-1 amd64 Jitsi Gateway for SIP
ii jitsi-meet 2.0.4548-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4074-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4074-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4074-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4074-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-197-g38256192-1 all WebRTC compatible Selective Forwarding Unit (SFU)

dpkg -l | grep prosody

ii jitsi-meet-prosody 1.0.4074-1 all Prosody configuration for Jitsi Meet
ii prosody 0.11.2-1 amd64 Lightweight Jabber/XMPP server
ii prosody-modules 0.0~hg20190203.b54e98d5c4a1+dfsg-1+deb10u1 all Selection of community modules for Prosody

Same story after update. Nothing helped untill I read comunelevico post.
No need to edit anything. Just reboot and then restart jicofo.
thx

replace localhost and enable callcontroll.It works for me. Thanks guy !

“No need to edit anything. Just reboot and then restart jicofo”

yes! this worked for me after attempting the edits and then reverting them back because it didn’t help.

Finally a reboot and a simple:

sudo systemctl restart jicofo

Outbound calls now work fine until another reboot. Then run command again and all is good till next reboot…

Attempting to edit the Service Unit files, I see jicofo is loaded via systemd-sysv-generator which appears to auto load the init.d file that actually starts/stops the jicofo service.

Anyone know a good way to set the other Jitsi services to start before Jicofo to avoid this problem in debian/ubuntu?

And should this be reported as a bug in the installer for the Ubuntu packages?

BTW i’m on Ubuntu 20.04 with default Jitsi package install + jigasi for in and outbound dial using secure domain with local prosody auth database.

yes in my case a clean install with latest stable version (as of 6/13/2020) had the issue, then I was able to simply restart the jicofo service to get things going again, till a reboot…

so i’m not sure about an upgrade condition.

The “right” fix might be to make sure Jigasi comes online before Jicofo no matter what via Systemd/init.d script changes. But I found enabling the rediscovery interval fixes the issue automatically via built in rediscovery:

In the file:
/etc/jitsi/jicofo/sip-communicator.properties

add a config item for the service rediscovery interval (value is milliseconds, this works out to 10 mins)

org.jitsi.jicofo.SERVICE_REDISCOVERY_INTERVAL=600000

Then reboot the machine. Now there’s no more issues with failed SIP calls due to Jicofo not detecting Jigasi right away at system startup due to services coming up in the wrong order.