Invite Button missing from Toolbar

Are you using component or muc to register jigasi in the xmpp server?
You have invite button in the toolbar setting: https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L53?

Sorry, had to look up the difference between component and muc.

We are using the default, component, as we did the quick install. This is true for the upgrade and the clean install.

We have not modified the default interface_config.js, so ‘invite’ still exists.

Is there anything in the logs I can look for?

Thanks again!

When opening the page you should see Sip gateway enabled: true in your js console logs.

Ok, I see that on the server that has not been upgraded. I’ll have to try the upgrade again and look for that.

After upgrading to the latest, I see in the log Sip gateway enabled: false.

I upgraded using:
apt-get install -y jitsi-meet
apt-get install -y jigasi

invite button missing after upgrading to the latest version but no problem for incoming calls

I think there is a problem (or a new configuration that I don’t know) in the latest stable release.

2020-05-09T09:10:50.475Z [modules/xmpp/moderator.js] <u.parseConfigOptions>: Sip gateway enabled: false
Jigasi is working well (IN and OUT including the HEALTH_CHECK) but no button “+” is on the screen.

There is for sure a problem, after the upgrade the invite disappeared also to my instance. In the console log i read Sip gateway enabled: false.
Jigasi works perfectly for incoming calls

Are you using any authentication?

No auth, free login and clean installation. Single server installation.
Jigasi successfully authenticated to prosody via “callcontrol” and sip trunk ok with the sip proxy.
Incoming calls ok, ping calls (from jigasi deamon) ok, ‘+’ button missed.

Thanks damencho

Same problem here !

2020-05-13T14:11:57.610Z [modules/xmpp/moderator.js] <u.parseConfigOptions>: Sip gateway enabled: false

Resolved: I forgot to enable call_control on /etc/jitsi/meet/HOSTNAME-config.js

// Call control component (Jigasi).
call_control: ‘callcontrol.HOSTNAME’,

Thanks a lot… it’s working now. Appreciated!

This got me a step closer, the invite button now appears, but I get “Failed to add participants” when I dial an extension. I also see “Error inviting phone number” in the console log.

It’s odd because the Call Control entry was disabled on the previous version and dialing out worked fine.

Thanks again!

Yeah. Same problem to me. Changing the call_control setting leads to Failed to add participants after dialing. Without call_controll setting no plus sign.

cheers, t.

Actually I confirm as well the same problem. + button ok but impossible to add participants

I tried to reinstall on a new server and I have the same problem: + button ok but impossible to add partecipants.

I have the same issue after upgrade. My Invite (+) was present and working, but after upgrade it disappeared. Inbound calls still work.

I tried enabling call_controll , plus sign is back, but fails to add participants.

What’s worse i there’s no log output upon hitting the invite button to help isolate the issue.

Fixed mine by adjusting the below items. In my case, it seems related to prosody having updated at the same time as jigasi. I assumed it was a jigasi issue, but I think this is related to certs becoming invalid after prosody updates.

  • /etc/jitsi/videobridge/sip-communicator.properties
    replace =localhost your domain to the line below
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=YOUR.DOMAIN.HERE
  • /etc/jitsi/jicofo/sip-communicator.properties (add the line below)
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true
  • sudo systemctl restart jitsi-videobridge2
  • sudo systemctl restart jicofo
1 Like

In my case seams that is not necessary modify /etc/jitsi/videobridge/sip-communicator.properties and /etc/jitsi/jicofo/sip-communicator.properties.

Simply I restarted the jicofo service, after a reboot of machine, and I can use jigasi for outgoing call without problem.

I think that there are a problem with the order which the services start on my Debian machine.

This is the version of my distribution and packages:

Debian Buster 10.4

dpkg -l | grep ji

ii jicofo 1.0-567-1 all JItsi Meet COnference FOcus
ii jigasi 1.1-107-g6928850-1 amd64 Jitsi Gateway for SIP
ii jitsi-meet 2.0.4548-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4074-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4074-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4074-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4074-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-197-g38256192-1 all WebRTC compatible Selective Forwarding Unit (SFU)

dpkg -l | grep prosody

ii jitsi-meet-prosody 1.0.4074-1 all Prosody configuration for Jitsi Meet
ii prosody 0.11.2-1 amd64 Lightweight Jabber/XMPP server
ii prosody-modules 0.0~hg20190203.b54e98d5c4a1+dfsg-1+deb10u1 all Selection of community modules for Prosody

I’m having the same issue as everyone else here. I have 2 instances of Jitsi working well and tried to upgrade both of them this weekend to the latest versions. The + disappeared on both instances.

I followed the suggestion above by enabling call control. This was never enabled but both instances were working without any issues.

Enable call_control on /etc/jitsi/meet/HOSTNAME-config.js
// Call control component (Jigasi).
call_control: ‘callcontrol.HOSTNAME’,

Now the + appears, but trying to call someone it reports back ‘Failed to add participants’.

I also tried the other recommended fixes above, but neither seemed to work.

Other Fixes attempted:

/etc/jitsi/videobridge/sip-communicator.properties
replace =localhost your domain to the line below
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=YOUR.DOMAIN.HERE

/etc/jitsi/jicofo/sip-communicator.properties (add the line below)
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true

There also seems to be a few other posts related to this - may be related to a timing issue. Although, I have still not be able to get it to work.