Invitation Link does not contain custom HTTPS Port 8391

This is a Debian Bullseye Jitsi-Meet installation.
I am trying (after a while) to get JiGasi working.
I changed the HTTPS Listen Port in Apache2 config from 443 to 8391 in order to see my Jitsi-Meet Start-Page at https://–FQN–:8931

To get there I updated ./meet/–FQN—config.js:
bosh: ‘//–FQN–:8391/http-bind’
dialInNumbersUrl: ‘https:/–FQN–:8391/dialin.json’
dynamicBrandingUrl: ‘https://–FQN–:8391/asp/jitsibranding.asp’

Furthermore I updated ./videobridge/jvb.conf
websockets {
enabled = true
domain = “–FQN–:8391”
tls = true
}
(Not sure if this is necessary, but I did a grep -nirs on my Jitsi config.)

Everythins still looks good.
I open a Conference:
I log in as administrator
I select [INVITE] in the users dropup menu and copy the invitation link:

But the link isn’t working. The link is without the :8391 port.

What do I miss?

Might be a bug on our end. Nonstandard ports are less common these days so we might have missed something. A PR would be welcome.

Not sure how to do a Pull Request for this topic.
Maybe someone else could do that?
I was trying to avoid all this npm hassle I suffered last time when I installed from GIT, and after a year or so I ran into real problems having upgraded my Debian OS to the current release.
Another thing, the invite email message doesn’t contain the protocol prefix (https://) nor does it contain the custom port either in the invitation url presented. So the email is pretty much useless for people whose internet talents end at clicking on a link.
Is there a template for the invitation email?

Honestly I doubt many people are running setups in nonstandard ports. With free TLS certificates there is no need really.

We fixed those git URL link problems… well, npm also got their shit together :slight_smile:

It should contain the URL. The template is inside the code, but it varies depending on the operation. Can you show a sample of what you get?

Thank you. I will disagree to your first point though.
I use the Letsencrypt DNS mechanism to pull my certs, so no need for standard ports
and those people scanning the net for those :slight_smile:

This is the resulting mail: (There is no tag available, so lets see what’s happening)

[header] MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="------------216224E8946AC87FBA583848" Content-Language: en-US X-Virus-Scanned: Maia Mailguard 1.0.4

This is a multi-part message in MIME format.
--------------216224E8946AC87FBA583848
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit

xxx is inviting you to a meeting.

Join the meeting:
–FQN–/NotoriousCitiesEvacuateDeliberately

[signature]

--------------216224E8946AC87FBA583848
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

<meta http-equiv="content-type" content="text/html; charset=UTF-8">
xxxis inviting you to a meeting.

Join the meeting:
--FQN--/NotoriousCitiesEvacuateDeliberately
--
[signature]

Did you configure inviteDomain in dynamic branding?

I now did by adding “https://” there.
Result in my Invite-Email:
Join the meeting:
https://–FQN–/NotoriousCitiesEvacuateDeliberately
To join by phone instead, tap this: +49-911-…
Well I hope this doesn’t break somewhere else since this is not really a FQN with the https:// prefix.

Is the link correct now or not? I know that’s not a valid FQDN, but I saw some code in there that looks like it ignores everything and just adds whatever that setting is set to, verbatim.