InterfaceConfig not defined

Hi
The app is working well when i quick installed but when I changed my hostname it shows interfaceconfig not defined

Did you configure the interface config file?

nano /usr/share/jitsi-meet/interface_config.js

If not, I thing you can use the default one and start from there :slight_smile:

I did but only for the app name and such. Should i edit other things as well?

Also, if you are not a seasoned linux user, here is a command that is helpful to find stuff on your server:
First switch to the root folder of you system:
cd /

Then find what you are looking for

find . -name "*interface*config*"

NOTE:
find . -name means you want to find something, by name
You put the text you are looking for between quotes "text goes here"
the * character is a wildcard that means any character(s)

Let me look at mine… But leaving it stock should not cause issues

Yes, after installation it works fine. But when I configured it to have DocumentRoot on var/www/html it happened

I do not understand the document root you are reffering to… did not alter such a setting on my instance

Also, if you changed your host name, don’t forget to do the appropriate modifications in the
etc/hosts file ! I learned the hard way (took me a loooong time to debug the issue as logs don’t give usefull information when your issue relates to this!)

So, should I put IP then url?

This is how mine is setup (skipping the ipv6 part lower)

127.0.0.1 localhost
127.0.0.1 [yourdomain.com]
xxx.xxx.xxx.xxx [yourdomain.com]

replace xxx.xxx.xxx.xxx by your ip
replace [yourdomain.com] by the adress of your domain (without the [ ])

Can it have subfolder? Like fqdn/folder? It seems like its not working if that is the case

@damencho tagging just to try if you can help me with this one. Thank you.

I can’t tell, sorry, it does not reflect my own setup

I have jitsi successfullt runnning on VS ubuntu machibe (8GM Ram) . Can you please help me setting us jibri to work. I could not any information how to set the config.json jibri file. Paid work is our preference.