interfaceConfig is not defined

We are a literature club of old persons sensible to the Corona Virus and we though that videoconferencing could enable us to maintaint our meetings and I need for another project to integrate a videoconference into a web site. So Jitsi-meet could be the great solution.

I made the quick install but apart from the https + certificates, I am stuck into the configurations.

The Web browser indicate interfaceConfig is not defined via the console and stay gay anyway.

Feel free to access it: https://meet.iamtheowner.com/

Annexed my configuration files and logs… I have try so many variants that next step is delete everything and start again ou abandon. I save the config and logs into my website:

My configs:
https://www.iamtheowner.com/Jitsi-meet/meet.iamtheowner.config

Prosody:
https://www.iamtheowner.com/Jitsi-meet/prosody.log
https://www.iamtheowner.com/Jitsi-meet/prosody.err

Videobridge:
https://www.iamtheowner.com/Jitsi-meet/jvb.log

Jicofo:
https://www.iamtheowner.com/Jitsi-meet/jicofo.log

In Jitsi we Trust !
Hope that someone can help me.

Did you had nginx or apache pre-installed … when installing it. There are a lot of changes coming in the following weeks to the stable package.
You can try them out by moving to unstable Debian repo, purge all (uninstall instructions from quick-install guide) and install the packages from unstable. They default to using nginx activating more features by default and installing and configuring a turn server by default and configuring it to be used through nginx.

I installed NgInx by my self. My problem is more in the configuration files. I think I miss match things.

Hereby my nginx sites-enabled configuration:

https://www.iamtheowner.com/Jitsi-meet/iamtheowner.com.conf

How would you propose me to work on all this ?

Apparently ssi is not turned on for your nginx and this is the problem.

Big decision, I cleaned everything and reinstall. The place of the certificate was not correct so I choose to connect them directly into the lets

RSA certificate

ssl_certificate /etc/letsencrypt/live/example.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/example.com/privkey.pem;

Note that the .crt is not enough for the browsers and we need to provide the chain of trust with fullchain list of certificates.

It looks very nice !