Integration Google Calendar on self-hosted Jitsi server

Hi everyone,

I tried to follow this steps to implement a Google Calendar API on my self-hosted Jitsi server with my own domain : Google Calendar Inergration

But, I have no results after this configuration.

I need to do something else maybe ?

Thank you.

enableCalendarIntegration: true, in config.js

Hi @damencho , thank you for you reply.

I have already set the value enableCalendarIntegration to true and I have add too the value googleAPIApplicationClientID with my own clientID.

So, someone knows this issue ?
How I can check if it’s work or not ?

I am having a similar problem, except I now have the “Sign in with Google” available on the main page, but when I click it nothing happens whatsoever. I’ve tried this on Chrome and Firefox with no success.

I stuck here too.

I followed the guides, enable the calendar integration on config.js and add my own Google client ID, but nothing happens. I reboot the system several times with no luck.

EIDT: I enable the API too in my Cloud Console.

I got it!!!

You should edit /etc/jitsi/meet/[yourdomain]-config.js and here set the value to true and add the Google client ID!

Restart the VideoBridge and thats it!

Source

Hi @esturniolo, thank you for your help.

I have already set this value only in /etc/jitsi/meet/mydomain-config.js :

And of course, I have restart videobridge service and restart too the server.

Did you do something else ?

Not really.
I created the Client ID on Google side, set to true the line 294 on /etc/jitsi/meet/example.com-config.js and finally add the googleApiApplicationClientID line with the ID.

I know that because I wrote all step by step. The doc it’s a little tricky.

If you made some change in the other *-config.js, try to reverse it.

Finally I made a reboot to be sure that all the services will take the new changes. I know that restarting the services should be enough. But I saw that sometimes with Jitsi is better a reboot.

When I stuck like you, I tried to start over from scratch.
I mean:

  • Reverse all changes made regarding this (Calendar in this case)
  • Create a new app and ID on Google side
  • And uncomment the lines adding the new values (ID)

You will never know if you made a simple mistake that is blocking your current goal.

I’ve tried to configure all again but nothing change on my configuration.

I haven’t the calendar part on my web page, so I can’t Sign in with Google !

I really don’t understand why I can’t enable the feature Calendar.

You wrote API in capitals, it’s:
googleApiApplicationClientID

If the integration doesn’t work, please make sure you don’t block cookies on accounts.google.com.

That solved the problem for me (I was able to login to Google, but then it didn’t work. After unblocking this cookie, it worked.)

Thanks a lot, the problem was effectively the API in capitals !

I don’t know how i could miss that but now it’s solved.

1 Like

I also have the same problem. Did you solve it?

can someone help me to.

created a Google App ID for connecting jitsi with Google calendar and these are the scopes email
profile
openid
…/auth/calendar.events.public.readonly
…/auth/calendar.app.created
…/auth/calendar.events.freebusy

Anded these line Jitsi config file

enableCalendarIntegration: true,
googleApiApplicationClientID :“xxxxxx.apps.googleusercontent.com”,

“sign in with Google” button is appearing but when I clicked on that button nothing is happening no any pop-up window Nothing

Do I have to add redirect URL during app creation? But that’s not mentioned in the documentation.

@damencho hi, where can i find the config.js file?

/etc/jitsi/meet/yourdomain-config.js

1 Like

hi

Sorry for this question, i have only config.js file but i am not getting [domain]config.js file in server. but i got that in my local system. How can i get that in my server ?

Thank you

@Sukant

Are you using docker for your installation or did you installed with apt?

Regards